Post Reply

[Q] about flashing roms

OP wilbur753

21st June 2014, 11:17 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Jun 2014
I'm now using Samsung Galaxy S3 I9300 with android 4.1.2. Recnetly, I want to flash the S5 roms posted by other developers. However, those roms are in android 4.3 or 4.4.2. Can I directly flash it or do I need to upgrade my device to android 4.3 first?
thanks so much!
21st June 2014, 06:27 PM   |  #2  
bweN diorD's Avatar
Senior Member
Thanks Meter: 656
 
1,539 posts
Join Date:Joined: Jun 2011
More
You can't flash a s5 ROM onto your s3, it will brick.

Sent from my LG-VS980 using XDA Premium 4 mobile app
22nd June 2014, 08:16 AM   |  #3  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Jun 2014
Quote:
Originally Posted by bweN diorD

You can't flash a s5 ROM onto your s3, it will brick.

Sent from my LG-VS980 using XDA Premium 4 mobile app

But the S5 rom is for S3. I found that in the S3 forum. Can you briefly explain why it will brick?Thank you
22nd June 2014, 12:57 PM   |  #4  
bweN diorD's Avatar
Senior Member
Thanks Meter: 656
 
1,539 posts
Join Date:Joined: Jun 2011
More
Quote:
Originally Posted by wilbur753

But the S5 rom is for S3. I found that in the S3 forum. Can you briefly explain why it will brick?Thank you

ok, i looked into the s3 forum and i see the s5 rom there.
this is either a rare instance where another phones rom is compatible or more likely what is known as a "port". it wasnt obvious right off what was the case.
either way, sorry for the confusion, it would be ok to flash that as long as its says its compatible with your phone.
generally speaking, you cant just grab a rom for any phone and flash it to another. that would result in a brick, and i jumped to conclusions and thought that was what you were trying to do.
as far as, if you need to upgrade first, im not sure about that.
some roms require you to be on a specific version first, otherwise it will bootloop after you flash the rom.
reason being, roms dont usually replace all parts of the software, but are built off or made to work with certain versions specifically because the use some of those non replaced parts to work correctly.
i would read through a few pages of the rom post. most likely someone has asked if it will work on whatever version or stated what version you need to be on for it to work.
if you cant find any answer, then i would ask the question there.

sorry i cant be of more help.
one bit of advice that i always follow myself, read into flashing back to stock and download all needed files and tools first. this way, if you have any issues, or just dont like the rom, you already have a backup plan in place to get your phone working again like you want it.
just my 2c hope that helps.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Questions and Answers by ThreadRank