FORUMS

Analysis & Opinion

[Q] Problem after unlocking my phone

3 posts
Thanks Meter: 0
 
By Copic_Aleksandar, Junior Member on 22nd June 2014, 01:28 PM
Post Reply Subscribe to Thread Email Thread
After unlocking my Galaxy S3 i747 , my phone started having problems.
Problem description:
-My calls break up
-Data internet is always on E and G and i so slow
-and sometimes i lose my network signal

I am from South-Eastern Europe, Serbia. I bought my phone in Canada, and he was locked for Virgin Mobile Canada.

Pls help.
THX
 
 
22nd June 2014, 01:39 PM |#2  
audit13's Avatar
Senior Member
Flag Toronto
Thanks Meter: 2,390
 
More
Did you unlock the phone with a code? Unlocking by code should have cause these problems.

Does your provider use AWS (1700/2100) frequency bands?
22nd June 2014, 02:06 PM |#3  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by audit13

Did you unlock the phone with a code? Unlocking by code should have cause these problems.

Does your provider use AWS (1700/2100) frequency bands?



I didn't unlock it, i gave it to service to unlock it so i don't know what they did ...
22nd June 2014, 02:09 PM |#4  
audit13's Avatar
Senior Member
Flag Toronto
Thanks Meter: 2,390
 
More
Who is your carrier? Is the model # correct under the phone settings?
22nd June 2014, 02:17 PM |#5  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by audit13

Who is your carrier? Is the model # correct under the phone settings?

By carrier You meen Mobile Operator?
Sorry, i am a noob for this things..
22nd June 2014, 02:32 PM |#6  
audit13's Avatar
Senior Member
Flag Toronto
Thanks Meter: 2,390
 
More
Quote:
Originally Posted by Copic_Aleksandar

By carrier You meen Mobile Operator?
Sorry, i am a noob for this things..

Yes, mobile operator. Is your phone the i747 under settings?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes