CPU Spy Gets an Android Lollipop Makeover

At some point in the distant past, you probably heard of CPU Spy for Android by XDARetired … more

Amazon Fire TV Stick vs Chromecast – XDA TV

There is no doubt that Amazon is a huge player in many markets, and they want to be a huge … more

Fight the Heat and Conserve Battery with EaseUS Coolphone

Memory hungry Android applications are often responsible for making our device … more

Battery Charged in 30 Seconds? Maybe in 2016

Phones and tablets are getting more and more power hungry with each passing generation. Their … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Problem after unlocking my phone

OP Copic_Aleksandar

22nd June 2014, 02:28 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Jun 2014
After unlocking my Galaxy S3 i747 , my phone started having problems.
Problem description:
-My calls break up
-Data internet is always on E and G and i so slow
-and sometimes i lose my network signal

I am from South-Eastern Europe, Serbia. I bought my phone in Canada, and he was locked for Virgin Mobile Canada.

Pls help.
THX
22nd June 2014, 02:39 PM   |  #2  
audit13's Avatar
Senior Member
Toronto
Thanks Meter: 866
 
3,023 posts
Join Date:Joined: Jun 2012
More
Did you unlock the phone with a code? Unlocking by code should have cause these problems.

Does your provider use AWS (1700/2100) frequency bands?
22nd June 2014, 03:06 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Jun 2014
Quote:
Originally Posted by audit13

Did you unlock the phone with a code? Unlocking by code should have cause these problems.

Does your provider use AWS (1700/2100) frequency bands?



I didn't unlock it, i gave it to service to unlock it so i don't know what they did ...
22nd June 2014, 03:09 PM   |  #4  
audit13's Avatar
Senior Member
Toronto
Thanks Meter: 866
 
3,023 posts
Join Date:Joined: Jun 2012
More
Who is your carrier? Is the model # correct under the phone settings?
22nd June 2014, 03:17 PM   |  #5  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Jun 2014
Quote:
Originally Posted by audit13

Who is your carrier? Is the model # correct under the phone settings?

By carrier You meen Mobile Operator?
Sorry, i am a noob for this things..
22nd June 2014, 03:32 PM   |  #6  
audit13's Avatar
Senior Member
Toronto
Thanks Meter: 866
 
3,023 posts
Join Date:Joined: Jun 2012
More
Quote:
Originally Posted by Copic_Aleksandar

By carrier You meen Mobile Operator?
Sorry, i am a noob for this things..

Yes, mobile operator. Is your phone the i747 under settings?
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes