Default [Q] Android Studio “install_failed_invalid_apk” error

Hi.

Im trying to debug a app in Android Studio, but every time i run the app to the phone it says:

Code:
Select Code
Installing com.myapplication2.app
DEVICE SHELL COMMAND: pm install -r "/data/local/tmp/com.myapplication2.app"
pkg: /data/local/tmp/com.myapplication2.app
Failure [INSTALL_FAILED_INVALID_APK]
Log

Code:
Select Code
06-22 21:20:07.908    5072-5083/com.android.defcontainer W/zipro﹕ Unable to open zip '/data/local/tmp/com.myapplication2.app': Permission denied
06-22 21:20:07.908    5072-5083/com.android.defcontainer D/asset﹕ failed to open Zip archive '/data/local/tmp/com.myapplication2.app'
06-22 21:20:07.910    5072-5083/com.android.defcontainer W/PackageParser﹕ Unable to read AndroidManifest.xml of /data/local/tmp/com.myapplication2.app
    java.io.FileNotFoundException: AndroidManifest.xml
            at android.content.res.AssetManager.openXmlAssetNative(Native Method)
            at android.content.res.AssetManager.openXmlBlockAsset(AssetManager.java:487)
            at android.content.res.AssetManager.openXmlResourceParser(AssetManager.java:455)
            at android.content.pm.PackageParser.parsePackageLite(PackageParser.java:729)
            at com.android.defcontainer.DefaultContainerService$1.getMinimalPackageInfo(DefaultContainerService.java:173)
            at com.android.internal.app.IMediaContainerService$Stub.onTransact(IMediaContainerService.java:110)
            at android.os.Binder.execTransact(Binder.java:367)
            at dalvik.system.NativeStart.run(Native Method)
06-22 21:20:07.910    5072-5083/com.android.defcontainer W/DefContainer﹕ Failed to parse package
06-22 21:20:07.911      364-386/system_process W/ActivityManager﹕ No content provider found for permission revoke: file:///data/local/tmp/com.myapplication2.app
06-22 21:20:08.101      364-386/system_process D/dalvikvm﹕ GC_EXPLICIT freed 90K, 16% free 47127K/55479K, paused 5ms+30ms, total 191ms
I´m able to install the apk by copying to sdcard and installing directly from Android.

Tried to change /data/local folder permissions to 755, but the issue remains.

This started to happen after:
a) Updated my Android to a custom rom
b) Updated Android Studio from 0.4.6 to 0.5.2

But since both updates were simultaneously, cant say which one is responsible for this error.

Any help is appreciated.

Using Windows 8.