Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,786,599 Members 38,534 Now Online
XDA Developers Android and Mobile Development Forum

[Firmware][Unofficial][ODIN]S4 DevEd[boot/recovery/radio/modem][MDK-MJ7-MK2-NC5]

Tip us?
 
k1mu
Old
#91  
k1mu's Avatar
Recognized Contributor
Thanks Meter 1,544
Posts: 1,908
Join Date: Apr 2011
Location: Virginia

 
DONATE TO ME
Quote:
Originally Posted by gavron View Post
Further update in case this helps anyone else or triggers a thought.

When using Philz to flash CM11, Philz reports

E: Error loki-ifying the boot image.

I have manually pulled aboot.img, boot.img, and ran loki_tool to find out that:
Code:
/data/local/tmp # loki_tool patch boot aboot.img boot.img out.lok
Loki tool v2.1
[-] Failed to find function to patch.
From examining the source code it appears the code in loki_patch.c looks for
a set of patterns ("fingerprints") of the target code. The new VZW DEV ROM Aboot
does not appear to have any of those.

Is this the right conclusion? Do I need to wait for someone to release a new loki_patch
that can handle this new aboot... or is there a different method?

Thank you all,

Ehud
If you have a Developer Edition phone, the bootloader is unlocked. You don't need to use Loki to bypass it.
My Android devices:
vzw Samsung Galaxy S4 stock NC5 rooted
Samsung Galaxy Tab 2 10.1, also stock but rooted.

VZ Droid Incredible 2 rooted but otherwise stock.
Samsung Galaxy Tab 10.1
 
Skeetch79
Old
#92  
Skeetch79's Avatar
Senior Member - OP
Thanks Meter 159
Posts: 232
Join Date: Oct 2010
Location: West Milford, NJ
Quote:
Originally Posted by gavron View Post
EDIT: Update: Your version of Philz works fine! Thank you! And also, I have a clockworkmod nandroid backup that doesn't work (com.google.gapps constantly dies on the restored version), a TWRP backup that works great to get back to virgin Samsung OS, and am now doing a Philz backup as well.

Thanks for lots of good info. I will try your version of Philz and see if that runs or gives me the no run error.
(Note: I use linux but am confident that heimdall flash is equivalent to Odin. It worked for TWRP and CWR...)

- Why did I try VRUAMDK? Originally when I got the first one of these (DEV) it was running VRUAMDK.
At the time I could flash whatever I wanted. TWRP + CM11 ran fine. Then I put the wet-apply screen protector
on it and the digitizer&screen died. While repairing that, Samsung "did me a favor" and flashed it locked.
After six months of back and forth I now have two of the I545OYUFNC5s and they allow me to flash SOME
things with no issues.

- I cannot get CM11 or CM10 or Team Gummy ROMS to work now. THEY DID WORK ON THIS PHONE
BACK before I gave it to Samsung. I'm assuming the new Aboot is preventing them from running.

- I *can* get a touchwiz-based Jely-Bean to run (jfltevzw_JellyBeans_B7) if I select its installer's safestrap
option. This also provides the seandroid enforcing message and 30+ seconds later times out and boots
the rom.

- What is the ultimate goal of my use of this dev phone? I would like to run custom builds based on CM10&CM11
to test various things. I currently have a DEV VZW MotoX, a DEV TMO MotoX, and these two DEV VZW S4s.
SO I get when you're saying "we were all n00bs but please do research ..." and "...you can install kernels and
systems..." My requirements are not that complex, but I'm unable to get CyanogenMod to run. THAT right now
is the biggest hurdle.

Thanks for taking the time to detail your answer! I hope I've clarified further.

E
Sorry it has taken me a while to reply, busy weekend with the 3 kids, 2 dogs, wife and other family. Glad to hear Philz worked for you. It has basically been my go to recovery. After the upgrade from MDK I have not had any success with TWRP, the Loki exploit was patched after MDK which is also why the amount of ROMs which you can run have dwindled (hence why you are having issues with CM Roms) - with MDK you could basically run anything! Oddly enough, SafeStrap ran fine while I was on MJ7/MK2 and that utilized TWRP as it's recovery - had no issues with TWRP in this fashion, just as a standalone recovery.

I find it hard to believe that the original Firmware on your Dev phone was I545VRUAMDK, when Developer phones would have run I545OYUAMDK, unless Samsung forgot to change the baseband/Build information. Interesting nonetheless.

My experience with Samsung has been less than par as well. I started out with an OYUMDK and after paying close to $700 in September of last year for the phone and then finding out we would never have software updates, etc, I sent an email to someone at Samsung. That started a ball rolling where I was able to have the device upgraded to MJ7 then MK2 and then finally NC5. It shouldn't have to be that way. (Some argue is not the point of having a Developer phone - and I agree, but software upgrades are nice. The Moto Developer Ed phones get upgrades, as well as the HTC Developers). After my time with this device - which I cannot complain about the Camera, though TouchWiz sucks - I will definitely look to get back in the Moto world with one of their Developer Edition phones. I took a chance with Samsung after having a Droid X, Droid Bionic and Droid Razr and stepped outside of my comfort zone . I should've stayed within the Moto walls!

But I hope I can help moving forward if you have any other questions or issues.
 
00negative
Old
#93  
00negative's Avatar
Senior Member
Thanks Meter 151
Posts: 554
Join Date: Aug 2010
I got rid of the custom system status on mine but can't get rid of the custom binary designation?? And triangle away doesn't seem to reset the flash counter. Chainfire's G+ says that had been an issue on 4.3 devices that show a custom system status or binary.

Odin won't let me flash stock radio files says Auth (fail). Any one have any ideas?

Dev edition with MJ7 currently

Sent from my SCH-I545 using Tapatalk
Tags
developer, edition, i545oyuamdk, i545oyuemj7, i545oyuemk2
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes