Default [Q] How to enable soft menu keys? [Solved]

Is there a way to enable soft keys like Nexus or Moto X? I'm not looking for an app that fakes the behavior.
I have a Note 3 4.4.2 Kitkat (NC2).


edit: I found it working well, so I am updating this post.

[Enable soft menu keys]
edit "/system/build.prop", and add at the bottom:
Code:
qemu.hw.mainkeys=0
[Optional] Disable hardwired buttons.
edit "/system/usr/keylayout/Generic.kl", comment out these two lines so it looks like this:
Code:
# key 139 MENU
# key 158 BACK
After using a while, I found it works best if I keep the hardware buttons enabled too. Back key is now on both left and right side so it's easier to reach when using with one hand.


[Optional] Disable 3-dot menu button. When you enable soft-keys, there will be an additional menu shown in every app. This could waste lot of space. You should have Xposed mod installed, then look for Noverflow, and install that.
Noverflow xposed mod.
This doesn't work on Galaxy S5 Port Update 4 ROM, but works well with stock NC2 ROM.

[Optional] Once softmenu keys are added, you have less screen space. The Dialer app doesn't know how to scale, so you would have the bottom row keys chopped off a bit. You can make change the DPI settings so it'll shrink and be able to see everything.
Default screen DPI is 480. I changed it to 450.
Edit file "/system/build.prop", look for the line with "ro.sf.lcd_density=480" and edit so it looks like this:
Code:
ro.sf.lcd_density=450
[Optional] Remove AT&T wifi autoconnect.
I don't know why, but even if I uncheck autoconnect AT&T wifi, it still keeps trying. And you can't really remove the profile either.
Edit "/data/misc/wpa_supplicant.conf"
Look for ssid="attwifi", change that to something like this:
Code:
ssid="attwifi-sucks"
Attached Thumbnails
Click image for larger version

Name:	capture.jpg
Views:	33
Size:	70.6 KB
ID:	2815553