Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,771,526 Members 50,172 Now Online
XDA Developers Android and Mobile Development Forum

[Q] MTK6575 i9505 - 3G don't work! How to fix?

Tip us?
 
fmatheus2003
Old
#1  
Member - OP
Thanks Meter 0
Posts: 41
Join Date: Jan 2014
Default [Q] MTK6575 i9505 - 3G don't work! How to fix?

Hi guys,

I've bought a phone tha is a poor S4 clone.
MTK Root and Tools recognized it like this:

Hardware : MT6575 (MT6517 is Fake!)
Model : GT-I9505
Build number : Android ICS
Build date UTC : 20130725-095723
Android v : 4.1.1
Baseband v: MAUI.11AMD.W11.50.SP.V31.P2, 2013/05/09 17:21
Kernel v : 3.4.0 (wanglei@wanglei-desktop) (gcc version 4.4.3 (GCC) ) #1 Thu Jul 25 17:51:08 CST 2013
Uboot build v : MAIN2.2.ubt.3327
LCD Driver IC : 1-ili9806_6575_dsi

The thing is: The UMTS (3g) network don't work. It only connects through Edge network.

I've tried to restore IMEI - nothing happens...
I've used the MobileUncle tools to see the bandmode, but it shows only the 2g network (the umts mode is grey, and I can't set it up...)

My first theory was that the firmware doesn't support the 3g network, but, since I couldn't find a best firmware, that theory was... stuck.
My second theory was that this SoC (MTK6575) doesn't have 3g access but after some research i saw a lot of people tha have the same SoC and connects to this network, so...

Well, this is my story... someone can help me? Thanks in advance...
 
zelendel
Old
#2  
zelendel's Avatar
Moderator Committee - The Dark Knight
Thanks Meter 10953
Posts: 14,332
Join Date: Aug 2008
Location: Watching from the Shadows

 
DONATE TO ME
Quote:
Originally Posted by fmatheus2003 View Post
Hi guys,

I've bought a phone tha is a poor S4 clone.
MTK Root and Tools recognized it like this:

Hardware : MT6575 (MT6517 is Fake!)
Model : GT-I9505
Build number : Android ICS
Build date UTC : 20130725-095723
Android v : 4.1.1
Baseband v: MAUI.11AMD.W11.50.SP.V31.P2, 2013/05/09 17:21
Kernel v : 3.4.0 (wanglei@wanglei-desktop) (gcc version 4.4.3 (GCC) ) #1 Thu Jul 25 17:51:08 CST 2013
Uboot build v : MAIN2.2.ubt.3327
LCD Driver IC : 1-ili9806_6575_dsi

The thing is: The UMTS (3g) network don't work. It only connects through Edge network.

I've tried to restore IMEI - nothing happens...
I've used the MobileUncle tools to see the bandmode, but it shows only the 2g network (the umts mode is grey, and I can't set it up...)

My first theory was that the firmware doesn't support the 3g network, but, since I couldn't find a best firmware, that theory was... stuck.
My second theory was that this SoC (MTK6575) doesn't have 3g access but after some research i saw a lot of people tha have the same SoC and connects to this network, so...

Well, this is my story... someone can help me? Thanks in advance...
You were most likely right on the device not supporting the bands your carrier uses. Most cheap knock offs are set to use China's bands which don't match most of the rest of the world.

Bat cave One





If hard work pays off then easy work is worthless
SearchFu
Never Ask someone to do something your not willing to at least try to do yourself.
"Gotham is the work of a madman"- NunHugger Current Nexus 5-12 Nightly


 
fmatheus2003
Old
#3  
Member - OP
Thanks Meter 0
Posts: 41
Join Date: Jan 2014
Default Maybe...

Quote:
Originally Posted by zelendel View Post
You were most likely right on the device not supporting the bands your carrier uses. Most cheap knock offs are set to use China's bands which don't match most of the rest of the world.

Bat cave One
Well, my research says that the SoC Mtk6575 Works on WCDMA (3g) in 850/2100 MHz.
In Brazil (where I live) our carriers uses both bands...

The thing is: Maybe a diferente firmware could give me na option to set these bands and put this **** to work....
 
zelendel
Old
#4  
zelendel's Avatar
Moderator Committee - The Dark Knight
Thanks Meter 10953
Posts: 14,332
Join Date: Aug 2008
Location: Watching from the Shadows

 
DONATE TO ME
Quote:
Originally Posted by fmatheus2003 View Post
Well, my research says that the SoC Mtk6575 Works on WCDMA (3g) in 850/2100 MHz.
In Brazil (where I live) our carriers uses both bands...

The thing is: Maybe a diferente firmware could give me na option to set these bands and put this **** to work....

Just because the chip supports the bands means nothing. It is all about how the antenna is programmed. Most are programmed to work in the country they are released in.

A firmware will not change this. It is hard coded in to the antenna.





If hard work pays off then easy work is worthless
SearchFu
Never Ask someone to do something your not willing to at least try to do yourself.
"Gotham is the work of a madman"- NunHugger Current Nexus 5-12 Nightly


 
fmatheus2003
Old
#5  
Member - OP
Thanks Meter 0
Posts: 41
Join Date: Jan 2014
Default Hummm

Quote:
Originally Posted by zelendel View Post
Just because the chip supports the bands means nothing. It is all about how the antenna is programmed. Most are programmed to work in the country they are released in.

A firmware will not change this. It is hard coded in to the antenna.
Ok. I got it.

Is there any way to bypass this?
 
micheli_martins
Old
#6  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Jun 2014
Matheus:

Can you send me a complete copy from your room ? Or fix it for download?
I have the same cell phone that yours and it is bricking.
I don't find this room nowhere.



Quote:
Originally Posted by fmatheus2003 View Post
Hi guys,


I've bought a phone tha is a poor S4 clone.
MTK Root and Tools recognized it like this:

Hardware : MT6575 (MT6517 is Fake!)
Model : GT-I9505
Build number : Android ICS
Build date UTC : 20130725-095723
Android v : 4.1.1
Baseband v: MAUI.11AMD.W11.50.SP.V31.P2, 2013/05/09 17:21
Kernel v : 3.4.0 (wanglei@wanglei-desktop) (gcc version 4.4.3 (GCC) ) #1 Thu Jul 25 17:51:08 CST 2013
Uboot build v : MAIN2.2.ubt.3327
LCD Driver IC : 1-ili9806_6575_dsi

The thing is: The UMTS (3g) network don't work. It only connects through Edge network.

I've tried to restore IMEI - nothing happens...
I've used the MobileUncle tools to see the bandmode, but it shows only the 2g network (the umts mode is grey, and I can't set it up...)

My first theory was that the firmware doesn't support the 3g network, but, since I couldn't find a best firmware, that theory was... stuck.
My second theory was that this SoC (MTK6575) doesn't have 3g access but after some research i saw a lot of people tha have the same SoC and connects to this network, so...

Well, this is my story... someone can help me? Thanks in advance...
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


MacroDroid Update Brings Android Wear Automation

A few months ago, we talked about MacroDroid. For those who don’t remember, MacroDroid … more

Droid X Receives KitKat Port, Upcoming Google Glass Firmware Improvements – XDA Developer TV

Android 4.4.3 lands on the European HTC … more

Calc+ is a Smart and Beautiful Android Calculator

As we’ve said inthe past, there are quite a few calculators available on Android. … more

Get Better Debug Data with Crash Report SDK

Developing an application is a hard and often times ungratifying task. It also requires quite a … more