Post Reply

Neo M1 (4.2.2) Sound/Music Issue

OP sanders888

21st June 2014, 07:55 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
11 posts
Join Date:Joined: Sep 2011
Hi Guys,

Bit of weird one here!

I've just bought a Neo M1 (http://www.neomobile.me/neo-m1-feature)

It really is an amzing device for the price but support is non existent and as its a new device there arent many forums/discussions available. My issues seems to be more Android/OS based (i think) so hoping someone can help.

When playing music through speakers with the 3.5mm jack its fine, perfect. But when using earphones, and ive tried many, the music sounds like its is muffled or playing certain channels only. Vocals are low, effects are high and it not useable. Ive tried diffrerent music players and equalizers but nothing is working! Has anybody ever heard of this? Surely if it can play fine thorugh speakers it should be able to via ear/headphones?

Thanks in advance for any ideas!!

Sanders.
22nd June 2014, 05:51 PM   |  #2  
boofman's Avatar
Senior Member
Thanks Meter: 57
 
150 posts
Join Date:Joined: Oct 2010
have you checked to see if contacts are aligned properly?

Sent from my JY-G3N using Tapatalk 2
24th June 2014, 07:47 AM   |  #3  
Junior Member
Thanks Meter: 0
 
18 posts
Join Date:Joined: Mar 2009
I had the opposite effect on the iPod classic: with earphones/headphones, ok; thru jack connected to speaker/amp: muffled, distorted sound.
So had to use the Apple plug (wide plug connected at bottom) to connect to speaker/amp.
I guess it may be something to do with the impedance of the phone.
Would be interesting to know if others report the same issue, before I buy this phone.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Questions and Answers by ThreadRank