Get a Complete Set of Logs with Andy Log

The importance of proper logging is undeniable. No, we’re not talking about lumberjack work. … more

Try Some Android Lollipop Applications on Your Device

Android 5.0 Lollipop has been officially announced and lucky users of Google Nexus 5 … more

AutoCon Manages Your Connections to Perserve Battery Life

As we’ve talked about in the past, battery life is still somewhat of a sore … more

How to Unlock and Root a Nexus Device – XDA TV

It is official–Google has released the Nexus 6 and the Nexus 9. The Nexus family … more
Post Reply

[Q] Wifi issue with CM11

OP Pily95

31st May 2014, 03:32 PM   |  #1  
Pily95's Avatar
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Feb 2014
More
Hi everyone, I'm new on XDA
I currently have a ville (S4) with the latest snapshot of CM11 (M6) and I'm experiencing some issues with wifi signal:

When i connect to my router wifi works flawlessly, but after some hours it drops and seems like it can't reach any signal, neither from other router (my neighbours). If i reboot it, than it starts to work again.
This happens on any CM I've tried (10.1, 10.2, 11 various) and also on Pacman Rom but not with stock or sense based ROMs.

Is there anyone who has ever had this kind of issue or better a solution? Any help would be very appreciated

HBoot: 2.15
TWRP 2.7
ROM: CM11 (M6)
Radio: 1.20 (the one that comes with 2.16 package seen on MaximusHD install package)
SuperCID

PS: Sorry for my bad English, I'm italian...
Last edited by Pily95; 31st May 2014 at 03:37 PM. Reason: More explanations
3rd June 2014, 02:52 AM   |  #2  
Junior Member
Flag New York City
Thanks Meter: 4
 
15 posts
Join Date:Joined: Oct 2012
Donate to Me
More
I've experienced the same thing and it seems to be a common problem on this device outside of stock,
wifi will be working fine but then randomly drop all of a sudden and won't show any networks until you restart the phone. It will do it again after a little while from the restart. I came across a solution to this after trying so many different things, give it a shot.

http://forum.xda-developers.com/show....php?t=2769977

Let me know if it works for you and/or if you need help.

Good luck

---------- Post added at 02:52 AM ---------- Previous post was at 02:48 AM ----------

Quote:
Originally Posted by Pily95

Radio: 1.20 (the one that comes with 2.16 package seen on MaximusHD install package)

You might first want to try flashing a different radio, I've had nothing but bad luck with 1.20 on both sense and cm... random boot loops, gsm signal drops, etc...

Give this a read,


RADIO 1.35a.32.45.27, WCNSS, ADSP


Quote:

Q. Why is this radio recommended?

A. This radio has been proved better then the 1.20 radio by some of the users of One S and enables HSPA in 4.3 Sense based Roms like liberty.

Last edited by nSavage; 3rd June 2014 at 02:56 AM. Reason: elaborating
The Following User Says Thank You to nSavage For This Useful Post: [ View ]
3rd June 2014, 06:28 AM   |  #3  
Pily95's Avatar
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Feb 2014
More
Thank you very muck! I've just falshed the 1.35a radio and all what comes with that and now it seems to have no issue at all [emoji2] I'll keep testing for some days and I'll post here my results.

Inviato dal mio One S utilizzando Tapatalk
21st June 2014, 11:09 AM   |  #4  
Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Mar 2014
Hello,

I am quite new here and don't have permission to post in development section, but this topic seems to fit.

I am running CM11 nightlies with good success (very few reboots) since February. With all nightlies since June 14, WiFi cannot be activated anymore.

Some other users seem to have the same problem, some don't. I usually do "dirty" flashes with CM Update, but clean flashes don't help.

I can't find information about greater WiFi changes in log files. Any ideas?

Greetings from Germany

Matthias
24th June 2014, 12:48 PM   |  #5  
Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Mar 2014
Found the answer. Had to reflash boot.img because my One S is S-On. Now WiFi works as usual.

Greetings from Germany

Matthias

Gesendet von meinem One S mit Tapatalk
24th June 2014, 02:49 PM   |  #6  
Pily95's Avatar
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Feb 2014
More
Ok, after more than 20 days, I can say that the new radio (1.35a) posted by @nSavage works better with WiFi on my One S.
Again, thank you very much! [emoji2]

Inviato dal mio HTC One S utilizzando Tapatalk
Last edited by Pily95; 24th June 2014 at 02:54 PM.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes