Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,812,812 Members 51,099 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Charging problem

Tip us?
 
mandayugana
Old
#1  
Member - OP
Thanks Meter 8
Posts: 35
Join Date: Jan 2012
Default [Q] Charging problem

Hi,

My Lumia 900 only charges if I plug in the cable with force and I keep pushing it. I tried other cable and mobile charger, but no luck. Anyone experience this before? Any suggestions?

Thanks
 
Airbrushed
Old
#2  
Junior Member
Thanks Meter 0
Posts: 6
Join Date: Jan 2008
If you have tried multiple cables, it sounds, unfortunately, that it might be the Lumia 900's connector.
If you can shine a bright light into the connector (my eyesight would require me to use a magnifying glass now) just to check that there are no foreign objects like pocket lint; that might find something. While I had not had this happen to my Lumia 900, it had happened several years ago with my iPhone.
Otherwise, the connector might be loose from the main board, especially if the phone had ever taken a tumble while it was plugged in. Hopefully, it would be the former and not the latter.
 
mandayugana
Old
(Last edited by mandayugana; 24th June 2014 at 03:20 PM.)
#3  
Member - OP
Thanks Meter 8
Posts: 35
Join Date: Jan 2012
Quote:
Originally Posted by Airbrushed View Post
If you have tried multiple cables, it sounds, unfortunately, that it might be the Lumia 900's connector.
If you can shine a bright light into the connector (my eyesight would require me to use a magnifying glass now) just to check that there are no foreign objects like pocket lint; that might find something. While I had not had this happen to my Lumia 900, it had happened several years ago with my iPhone.
Otherwise, the connector might be loose from the main board, especially if the phone had ever taken a tumble while it was plugged in. Hopefully, it would be the former and not the latter.
I disassembled my Lumia 900 today. The port connection to the board seemed okay, but the body of the port which is made of plastics was cracked. It's all make sense why the phone charges only if I forcefully push the cable into the port.

So... I glued the cracked area of the port super glue then pressed it using a small clamp. After several minutes, the glue hardened. Done. I reassembled my phone and tested it. It worked.

I know this is not permanent solution and I don't know how long it will last. But, this is a workaround for user who doesn't have good technical skills of soldering like me.

Pictures:
Quote:
I didn't take any pictures when I disassemble my phone. I got these pictures through Googling.

The clamp:


Cracked area of the micro USB port:
see attachment. Red line is the crack.
Attached Thumbnails
Click image for larger version

Name:	cracked.JPG
Views:	2
Size:	9.4 KB
ID:	2815118   Click image for larger version

Name:	creacked 2.jpg
Views:	2
Size:	13.3 KB
ID:	2815119  
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes