An Android Enthusiast’s Apple iPhone 6 Challenge – XDA TV

The media has gone batty again over Apple “revolutionizing” … more

Sony to Extend its AOSP Program to Other Devices

Sony will be offering its users the possibility to use AOSP ROMs as an alternative to the … more

Project Ara Smartphone Will Run Modified Android L with Hot Swapping

Project Ara is a very exciting topic–both for hardware and … more

Streamline Android Theme Customization with Graphic Porter

I dont have a custom theme on my Android phone, and the reason for this is because … more
Post Reply

[Q] broke my xperia v

25th June 2014, 01:17 PM   |  #1  
ahmadfaiz's Avatar
OP Senior Member
Thanks Meter: 12
 
107 posts
Join Date:Joined: May 2012
assalamualaikum and good evening to everyone.. im using xperia v..lately my phone always got stuck especially when im charging it..the led is on but i can turn on the screen..usually i unplug the battery and reinsert it,then it would turn on again..but today after a few hours thinking how to solve the problem..i just cant..can anyone tell me why does this happen to me? of is it my software problem?? what should i do??

thanks in advance
27th June 2014, 02:46 PM   |  #2  
harrymason37's Avatar
Senior Member
Thanks Meter: 47
 
229 posts
Join Date:Joined: Jan 2014
Try to install safe charge
Or try to reset
Or repair it using pc companion

"gadgets need love too"
30th June 2014, 08:20 PM   |  #3  
ahmadfaiz's Avatar
OP Senior Member
Thanks Meter: 12
 
107 posts
Join Date:Joined: May 2012
Quote:
Originally Posted by harrymason37

Try to install safe charge
Or try to reset
Or repair it using pc companion

"gadgets need love too"

my phone cant be turn on..thats why i cant do anything 
1st July 2014, 01:53 PM   |  #4  
harrymason37's Avatar
Senior Member
Thanks Meter: 47
 
229 posts
Join Date:Joined: Jan 2014
Quote:
Originally Posted by ahmadfaiz

my phone cant be turn on..thats why i cant do anything 

I think it is hardware problem

"gadgets need love too"
1st July 2014, 02:04 PM   |  #5  
ahmadfaiz's Avatar
OP Senior Member
Thanks Meter: 12
 
107 posts
Join Date:Joined: May 2012
Quote:
Originally Posted by harrymason37

I think it is hardware problem

"gadgets need love too"

ive read some article saying that its the problem related to the battery..im not so sure about this..
1st July 2014, 02:16 PM   |  #6  
harrymason37's Avatar
Senior Member
Thanks Meter: 47
 
229 posts
Join Date:Joined: Jan 2014
In service center they can tell if you need to replace your battery

"gadgets need love too"
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Xperia T, TL, TX, V Q&A, Help & Troubleshooting by ThreadRank