Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,730,807 Members 42,659 Now Online
XDA Developers Android and Mobile Development Forum

[Q] LG Lucid 2 (VS870) Wi-fi & Un/rooting issues

Tip us?
 
k.imora
Old
(Last edited by k.imora; 25th June 2014 at 08:55 PM.) Reason: Issue 4
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Aug 2011
Default [Q] LG Lucid 2 (VS870) Wi-fi & Un/rooting issues

I've encountered a problem that I'm thoroughly convinced no one can help me fix (mostly due to the amount of time I've already put into seeking a fix). I recently rooted my phone, and it worked, but now I am starting to experience problems. I used VRoot to root the phone. All of the problems I'm experiencing happened after an attempt to boot my phone into recovery mode using the ROM Manager application.

PHONE INFORMATION

Model # - VS870 4G
Firmware - 4.1.2 (Jelly Bean)
Kernel version - 3.4.0-g2696711 lge@android-build
Build # - JZO54K
Software version - VS87012A

Issue 1:
My phone no longer connects to wi-fi. Upon selecting the connection and inputting the pass-code the phone only saves the connection but makes no attempts to connect. It can't possibly be the router that is causing the issue because the phone was able to connect flawlessly before I tried booting into recovery mode.

Issue 2:
My phone's status is currently "Rooted" but it doesn't behave like a rooted phone. When attempting to install applications that require root, the applications insist on informing me that my phone is indeed not rooted. When attempting to re-install lost applications after the numerous amount of hard resets I've done, the applications are shown to be already installed yet they are nowhere to be found on the phone.

Issue 3:
Even after installing the updated USB drivers (and multiple re-installs) any computer I plug the phone into refuses to recognize the phone if it is in Emergency mode, yet it is still recognizable in the default mode.

Issue 4:
In order to install apps, I have to download the .apk file because my phone will not connect to Google Play even when I'm directly connected to the internet via usb or using 4G. Various other applications that require an internet connection refuse to work as well which is making the troubleshooting process extremely frustrating.

Fixes I tried -
Reboot, hard reset, battery/SIM/SD removal, selecting the "Avoid poor connections" option, reset router, re-setup wireless connection (tried without a pass as well), switching the IP setting to "Static" (doesn't allow me to select connect if it is on static), toggled the 802.11g only mode, toggled the routers DHCP server option, unrooting phone (SuperUser deems it impossible due to the lack of a su binary, which I don't understand seeing that when the phone is in emergency mode the status of the phone is "Rooted"), installing a stock firmware install via KDZ, as well as failed attempts to manually install CWM (my purpose of trying to manually install CWM is due to a lot of the fixes I found having "being able to boot in recovery mode" as a requirement, which my phone lacks)

So here is/are my question(s):

If I'm not able to unroot the phone, is taking the phone to a manufacturer no longer an option?

Is there a way to "reset" the wireless hardware/software on the device directly that works around my current issues?

Are there any alternatives to installing the KDZ stock firmware file where the device isn't required to be in Emergency mode?

I'm still not exactly sure what a su binary is but is there a way to install it independently?


Thanks in advanced~
 
k.imora
Old
#2  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Aug 2011
And the intricate thesis pattern.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes