Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

LCD Digitizer Repair Fail

OP neverwinter

17th April 2014, 07:04 AM   |  #1  
OP Senior Member
Thanks Meter: 3
 
144 posts
Join Date:Joined: Oct 2007
I just replaced the digitizer and most of the housing for my 4G AT&T Xperia Play. It successfully turned on and charges, but the screen doesn't respond to my swiping or tapping. It does change orientation when the game pad is pulled out and the game pad does work since I can use it to navigate the menu when I press and hold the power button. Does anyone know what I messed up? And is there a ROM that allows the use of the game pad for all operations if I can never get the screen digitizer to work?

So now I can charge it and turn it on, but I can't swipe to open get past the lock screen...
Last edited by neverwinter; 17th April 2014 at 07:07 AM.
24th June 2014, 07:51 AM   |  #2  
OP Senior Member
Thanks Meter: 3
 
144 posts
Join Date:Joined: Oct 2007
Does anyone have any ideas, please?
25th June 2014, 11:24 PM   |  #3  
Senior Member
Flag Southern California
Thanks Meter: 71
 
981 posts
Join Date:Joined: Jun 2007
More
Besides not having the ribbon cables plugged in no I dont have any ideas. I replaced my screen once and it worked fine.
26th June 2014, 07:35 AM   |  #4  
OP Senior Member
Thanks Meter: 3
 
144 posts
Join Date:Joined: Oct 2007
Quote:
Originally Posted by scottmog

Besides not having the ribbon cables plugged in no I dont have any ideas. I replaced my screen once and it worked fine.

Thanks a lot for your reply. Maybe it is because I used super glue as an adhesive to glue the glass on?
26th June 2014, 11:43 AM   |  #5  
Senior Member
Flag Southern California
Thanks Meter: 71
 
981 posts
Join Date:Joined: Jun 2007
More
Quote:
Originally Posted by neverwinter

Thanks a lot for your reply. Maybe it is because I used super glue as an adhesive to glue the glass on?

I would not assume the super glue has anything to do with it unless you caked it on. Funny thing though, as soon as I did my old swap I realized how much worse the Chinese lcd was from the oem Sony screen. Weird ghosting and shadowing when moving in side scrolling games. Sold the Xperia and bought another one on Craigslist.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes