Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,782,032 Members 51,167 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Wifi problem in Galaxy S4 (I9505)

Tip us?
 
nef_kliens
Old
#21  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Jun 2014
Talking Thank you so much for this tip

Quote:
Originally Posted by Syed View Post
editing Built.prop done the job
you are great man

for anyone else trying to do this
you need to do
1) root
2) file explorer, i used "Total Commander"
3) go to File System Root>system
4) open built.prop with inbuilt total commander editor
5) search ro.securestorage.support=true, edit and change true to false
6) save then file and reboot

Regards to Frapeti
Hello,

I tried Frapeti's idea to change TRUE to FALSE and it works but to open the root system you need to install first the TOTAL COMMANDER APP so thank you also to you for giving me an idea on how to open the root system, but the problem is every time I edit the ro.securestorage.support=true, into false and save it, it says ERROR. I feel so frustrated coz I keep on looking for the solution for a week now, hassle, looks like hopeless, time consumings. So what I did is I tried again to look for another solution until I found this link where I downloaded the pre rooted rom: http://forum.xda-developers.com/show....php?t=2250824 that is match with my phone so please be careful on downloading so that it will not destroy your mobile, here's mine "PHONE: XXUFNB8"

After I downloaded Pre Rooted Rom that is match to my Phone Samsung Galaxy S4, the SUPERSU APP installed, nothing is change in my phone, no reset factory settings happened except the DEVICE/SYSTEM Official changed to CUSTOM (I dont care coz the important is the wifi will work again) and KNOW APP Disappear, i dont know where it goes. =)

Now heres the steps I did, this is a very BIG HELP from me that is not IT or COMPUTER LITERATE. Hehehe!

- Download the Pre Rooted ROM from this link, just follow the FLASHING INSTRUCTIONS:
http://forum.xda-developers.com/show....php?t=2250824
- Download Total Commander App
- Open Total Commander App (SuperSu will pop up and ask permission)
- Click GRANT
- Open File System Root
- Open build.prop
- Search ro.securestorage.support=true, edit and change true to false
- Click Save Button
- Reboot
- Enjoy Everyone

Sometimes updates from Samsung makes it worse and feel someone frustrated.

Finally I enjoyed my Samsung Galaxy S4. Thank you so much to the guys who keeps giving solutions to the problems like this. Sorry for my grammar. Hehe!

Nef
http://1broglobal.org
 
ravi2021
Old
#22  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Jun 2014
Default SOLVED

Quote:
Originally Posted by Katkoot_cena View Post
i did exactly what you said but nothing changed at all ..anyway thanks for trying to help

this is the problem's photo
::::::SOLVED::::::

Ok people, I had the same problem today for a couple of hours and a friend of mine had this problem for a month.

Problem Description:
When I click on the wifi option in the pull down menu, it turns to light green and stays the way for a long time before turning gray. At this point, I cannot scan available networks. Mobile data works option fine.
I tried the following solutions available on forums
1. Pull out the battery and turn the phone on -- DID NOT WORK
2. Turn the phone off and turn back on -- DID NOT WORK
3. Reset the phone to factory and delete all user data -- DID NOT WORK

Solution That Worked (for me):
I observed that when I was resetting the phone (for the 4th time) and in the second step when it asks for wifi networks, it was able to scan the networks and connect to a network. Then after following the rest of the steps in configuration(viz. samsung account login, google account login, etc.) the same issues starts back up.
If this is the case with you, reset your device to factory settings and when it asks for logging into samsung and google accounts be sure to uncheck restore from server option in both of them(but I think the main problem is mainly with samsung).
The wifi option turns on fine now. Then not go to settings>accounts and turn on backup and restore manually for both google and samsung one by one. The problem did not rise back up when I followed this process.

Environment Information:
Samsung S4
Kitkat 4.4.2
GT-I9505

Hope it helps.......
 
petrusconsult
Old
#23  
petrusconsult's Avatar
Senior Member
Thanks Meter 211
Posts: 403
Join Date: Jun 2012
Location: Somewhere In Time And Space
Quote:
Originally Posted by bbyoz View Post
Hy, I have a wifi problem with my upgraded S4, my wifi turns on but it connects only to my home wifi, if i want to conect to other wifi networks it says"find ip adress " and thats all, after that it`s start all over again to find ip adress and don`t connect. My friend with an S4 with 4.3 can connect to other wifi networks so i thinks is a problem with this update that i made to my phone. Anyone can fix this problem?
Eneter the wifi settings, by pressing for a while a wifi network name and disable proxy

MODEMS - BOOTLOADERS - KERNELS - FONTS :
CLICK :
SM-N9005 + SM-G900F + GT-I9505




Don't Forget To Hit The Thanks Button If You Like My Work Or If I Helped You !
 
i2i
Old
#24  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: May 2012
Quote:
Originally Posted by frapeti View Post
I'll make a flashable zip for it, else you can try to edit it on /system/build.prop

EDIT: try it: Attachment 2593316

Sent from my GT-I9505 using xda app-developers app



Thank You so Much it worked for me
 
jayman500
Old
#25  
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Jun 2014
Default head is busting with wifi not working

hello anyone
right basically the wifi wont graft, im in uk s4 international on ee. was a stock rom , ive tried the battery thing ive reset the phone and now ive rooted it using cm installer and its got cm11 on it. ive got odin v3.09 ive tried wif fix flash, with no joy. the base band version is XXUNFNC4. can any one help me get this sorted , im not an expert at all but i can follow layman intructions. ive read loads of threads and theres so much information about it im struggling to know which will help me . do i need a new bootloader? what ever that is? do i need a different rom? how can i fix this , its doing my head in.
pls help !
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes