Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

How to set up LTE on most custom ROMs (all LG G2 variants)

OP guitarmaniatico

26th June 2014, 12:42 AM   |  #1  
OP Senior Member
Thanks Meter: 14
 
128 posts
Join Date:Joined: Nov 2009
Hi
In many forums I saw people complaining on their LTE connections or even lost the option to set LTE.

I tried this and works fine on many custom ROMs

Type one of this codes in the phone dialer

D800: 3845#*800#
D801: 3845#*801#
VS980: 3845#*980#
LS980: 3845#*980#
D802: 3845#*802#
D805: 3845#*805#
(Other models just type model number between * and #)

Now you will see a hidden menu, follow the route: LTE-Only , Modem Settings , RAT Selection

Press LTE only, and restart your phone.
Then enter the hidden menu again, go to the same route, press: GSM / WCDMA / LTE auto.
Thats all, you are done!
Don't forget to hit the thanks button on the left if this works for you.
The Following 4 Users Say Thank You to guitarmaniatico For This Useful Post: [ View ]
26th June 2014, 01:09 AM   |  #2  
Senior Member
Flag Portland, OR
Thanks Meter: 61
 
525 posts
Join Date:Joined: Jan 2011
More
This didn't work for me on my TMobile G2 running CM 11 nightly 6/22. It says "USSD code running" and then "Connection problem or invalid MMI code".


Quote:
Originally Posted by guitarmaniatico

Hi
In many forums I saw people complaining on their LTE connections or even lost the option to set LTE.

I tried this and works fine on many custom ROMs

Type one of this codes in the phone dialer

D800: 3845#*800#
D801: 3845#*801#
VS980: 3845#*980#
LS980: 3845#*980#
D802: 3845#*802#
D805: 3845#*805#
(Other models just type model number between * and #)

Now you will see a hidden menu, follow the route: LTE-Only , Modem Settings , RAT Selection

Press LTE only, and restart your phone.
Then enter the hidden menu again, go to the same route, press: GSM / WCDMA / LTE auto.
Thats all, you are done!
Don't forget to hit the thanks button on the left if this works for you.

The Following User Says Thank You to adampdx For This Useful Post: [ View ]
26th June 2014, 01:28 AM   |  #3  
OP Senior Member
Thanks Meter: 14
 
128 posts
Join Date:Joined: Nov 2009
Quote:
Originally Posted by adampdx

This didn't work for me on my TMobile G2 running CM 11 nightly 6/22. It says "USSD code running" and then "Connection problem or invalid MMI code".

Ok try this:
Type on the dialer:

*#*#4636#*#*

Then tap in "Phone Information" (first option)
Scroll down to: Set preferred network type
Select: LTE/GSM/WCDMA

That's it man!

By the way, some carriers around the world use a SIM Card, for using LTE you have to update to a LTE SIM card, if you haven't done this contact your carrier and change your SIM card, it should be free.
Other carriers need to have your phone's IMEI and authorize it to give you access to a LTE network, contact your carrier if this is your case.

I hope I'm helping you my friend!
The Following 2 Users Say Thank You to guitarmaniatico For This Useful Post: [ View ]
26th June 2014, 05:49 AM   |  #4  
deadgiveaway's Avatar
Senior Member
Thanks Meter: 27
 
189 posts
Join Date:Joined: Apr 2014
Not of that worked on d803.... had to delete lteconf or apnsconf depending on rom then reset my apn to lte settings

Sent from my LG-D803 using XDA Free mobile app
26th June 2014, 03:43 PM   |  #5  
OP Senior Member
Thanks Meter: 14
 
128 posts
Join Date:Joined: Nov 2009
Deleting the file LTEconfig.apk works too on Optimus G3 ROM. I'm not sure of this in another ROM but anyone can copy the file in another location and back it up later.

The file is located in the folder: / System /app
Just delete the file and restart your phone. This should work too.
The Following User Says Thank You to guitarmaniatico For This Useful Post: [ View ]
26th June 2014, 11:34 PM   |  #6  
deadgiveaway's Avatar
Senior Member
Thanks Meter: 27
 
189 posts
Join Date:Joined: Apr 2014
Quote:
Originally Posted by guitarmaniatico

Deleting the file LTEconfig.apk works too on Optimus G3 ROM. I'm not sure of this in another ROM but anyone can copy the file in another location and back it up later.

The file is located in the folder: / System /app
Just delete the file and restart your phone. This should work too.

That never did it for d803 .... Probably cause the wrong apn is set to default ...??

Sent from my LG-D803 using XDA Free mobile app
27th June 2014, 04:27 AM   |  #7  
OP Senior Member
Thanks Meter: 14
 
128 posts
Join Date:Joined: Nov 2009
Quote:
Originally Posted by deadgiveaway

That never did it for d803 .... Probably cause the wrong apn is set to default ...??

Sent from my LG-D803 using XDA Free mobile app

Delete the file, don't worry. APN will be reconfigured automatically when you restart your phone (or radio), or if you search manually for a cellular network.
Last edited by guitarmaniatico; 18th August 2014 at 10:34 PM. Reason: More info that will be helpful for anyone

Post Reply Subscribe to Thread

Tags
all variants, lgg2, lte, lte problem
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes