Default [Q] Unable to get VoiceEngineWrapper (S-voice w/ gear on non samsung device)

I have a Nexus 4 and followed the tutorial on how to get things working on it in regards to the gear. Most of the stuff works now but i have an odd issue with s-voice:

When i open it on the gear, it will run, but the first time i run it after a restart, the phone shows an error: "Unable to get VoiceEngineWrapper"

On the gear, the voice sounds distorted and pitched with some weird echo. It also replies with "I didn't catch that" to whatever command i give it.

I tried to google the error i'm getting on the phone since i'm assuming it's connected, but nothing comes up. I was trying to get the google now voice engine to replace the s-voice tts since i've heard it can be done but i can't find any info on how to do it. Only thing i found was settings-tts-download us voice and set it as default.

If anyone smarter than me has some ideas on what in the world that error means or what else to try, I would appreciate it.

Thanks!