Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Kit Kat 4.4.2 Battery Drain!!

OP swc2001

18th June 2014, 11:21 PM   |  #21  
Mistertac's Avatar
Recognized Contributor
Flag Springfield, Ma
Thanks Meter: 2,267
 
4,288 posts
Join Date:Joined: Oct 2013
Donate to Me
More
Quote:
Originally Posted by esheesle

I use gsam to monitor stuff. Definitely got worse with 4.4.2 upgrade. "Android System" and "Android OS" are the top battery users (in normal battery mon and gsam) using about 5-7minutes of active CPU per hour. wlan_wd_wake(1hour 16 minutes in about 5 hours uptime) is the top wakelocker followed at a distance by Combined app wakelocks (32 minutes). wifi seems insanely high to me but might be right. thoughts?

Used greenify before and loved it, but can't really greenify android system/os or wifi.

And have you turned " always scanning " to OFF under WiFi advanced??

Also try setting WiFi to " never " on when the phone is sleeping.

And if you can set your GPS to " device only " or the battery saving setting.

You could also try giving your phone a static IP address. May also be how the router is handling the dhcp end of it...

Sent from my SCH-I545 using Tapatalk
19th June 2014, 02:02 PM   |  #22  
Senior Member
Thanks Meter: 17
 
221 posts
Join Date:Joined: Nov 2010
I figured out my issue (i think at least). Android System was a top offender and when looking at wakelocks wifi was the worst. Did a factory reset and no issues (wifi blinking normally, not steady lit). Restored my apps and rebooted, issue came back. Went through every app I could think of that accessed resources on the network and finally came across Plex. I had it installed on mk2 and it was working just fine. I disabled "discover devices on the network" and suddenly android system dropped and screen became the big offender again. I did not change that setting when upgrading to nc5 so assume that it broke somehow on kitkat. So if you are having issues and running Plex, try that out.
19th June 2014, 07:09 PM   |  #23  
Senior Member
Thanks Meter: 17
 
221 posts
Join Date:Joined: Nov 2010
So after running for 7 hours or so now since disabling the plex network search I am getting equal or potentially better battery life than i was with 4.3. Looking at 2.5% battery drain with some screen use, but not a ton.
19th June 2014, 08:40 PM   |  #24  
Tulsadiver's Avatar
Senior Member
Thanks Meter: 301
 
496 posts
Join Date:Joined: Jul 2013
Quote:
Originally Posted by swc2001

So I just updated to Mk2 then directly to Kit Kat yesterday. So I was on MJ7 basically.
Since being on the new Kit Kat 4.4.2 NC5 update I have noticed a HORRIBLE battery life.
I used surges method to Get 4.4.2 with Root. Use to my battery would only drain 1% - 2% in standby mode to my way to work.
Today it burned 7%
Also when it is plugged in, and I am using it drains. (however I have frozen a few things and it slowly increases while being used.)
I have searched for an answer to this problem but to no avail. Can anyone tell me how to fix this? (please No battery widgets or apps... there must be something that is different from 4.3 that can be stopped to get back the battery I know and love)
Thank you in Advance!!

I wish you would have used Gigilies method instead. I can go up to 4.4.2, back down to 4.3, and back up again flashing a single tar file though odin. You can even do It through safestrap if you don't have a warranty and aren't worried about tripping the Knox flag.

Not only does the battery drain on the 4.4.2 roms but my phone gets as hot as a firecracker after continuous use.
Last edited by Tulsadiver; 19th June 2014 at 08:47 PM.
19th June 2014, 09:38 PM   |  #25  
Felimenta97's Avatar
Senior Member
Flag Ribeirão Preto
Thanks Meter: 2,327
 
7,843 posts
Join Date:Joined: Aug 2011
More
Ignore, I confused myself...
27th June 2014, 02:35 PM   |  #26  
Senior Member
Thanks Meter: 17
 
221 posts
Join Date:Joined: Nov 2010
Been a week since I found some odd behavior with Plex which was causing the wlan_wd wakelocks to happen draining my battery quite quickly. Since then I've determined that if I reboot my device, Plex still starts draining battery even with the network discovery option off. I installed Greenify and added plex to the list and took care of that problem.

Next problem up, Google+ occassionally gets stuck in an odd state where it keeps the device awake (but doesn't use cpu). If i open the app all I get is the header banner but no content. If I swipe close the app and reopen all is fine and the wakelock stops (for a while).

Finally, this morning I noticed my twitter app doing a similar wakelock hang open but no cpu.

Overall seems like 4.4.2 has some serious wakelock hanging issues causing apps to have problems. Hope 4.4.3 fixes it because its a real pain to monitor.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes