FORUMS

Charging port fell off!?!

5 posts
Thanks Meter: 0
 
By armando58, Junior Member on 27th June 2014, 05:12 AM
Post Reply Subscribe to Thread Email Thread
Ok, I have a big problem with my SW2. Last day I wanted to charge it and this happened. I can't open the charging port anymore! Any ideas?
Attached Thumbnails
Click image for larger version

Name:	DSC_0279.jpg
Views:	214
Size:	255.1 KB
ID:	2819742  
 
 
27th June 2014, 05:31 AM |#2  
adrianmignogna's Avatar
Senior Member
Thanks Meter: 54
 
More
Maybe try using a small Screwdriver and push it in the top slot of the port. (It will probably scratch your device a bit, but it's better than nothing, right?)
27th June 2014, 08:15 AM |#3  
Member
Thanks Meter: 7
 
More
This is exactly how mine was when I got it used. The oval rubber type thing pops out with a tooth pick or as suggested above a small screwdriver. I hunted for ages for a replacement but ended up having to make a new port cover from some of the watches packaging that is a similar material. As you still have it just super glue the oval port seal back onto the cover and you're done!
27th June 2014, 04:54 PM |#4  
kill_dano's Avatar
Senior Member
Thanks Meter: 58
 
More
Mine fell off the other day too. Super glue doesn't seem to hold it very well. I put it back on but it's fallen off 3 times. Every time I cut out the old glue residue and re-attach.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes