Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Battery drainage on CM11

OP warezhafid14

29th June 2014, 12:41 AM   |  #1  
warezhafid14's Avatar
OP Member
Thanks Meter: 0
 
34 posts
Join Date:Joined: Oct 2013
Hey guys!

i have a battery drainage on my i8190.

i'm on Novafusion's CM11.

Like if i leave my phone charged 100% and go to sleep i find it off in the morning.

i even tried greenify.

any suggestions?

kernel?

Thanks guys.
29th June 2014, 01:27 AM   |  #2  
tys0n's Avatar
Recognized Contributor
Flag Stockholm
Thanks Meter: 1,256
 
1,982 posts
Join Date:Joined: Nov 2010
More
You don't add anything for anyone to help with. Post a screenshot of your battery stats maybe, or even install betterbatterystats, wakelock detector or something to see what's causing the drain.
The Following User Says Thank You to tys0n For This Useful Post: [ View ]
29th June 2014, 04:30 PM   |  #3  
warezhafid14's Avatar
OP Member
Thanks Meter: 0
 
34 posts
Join Date:Joined: Oct 2013
Thx tyson.

Here's a screenshot of betterbatterystats
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-06-29-15-25-15.png
Views:	81
Size:	81.1 KB
ID:	2823840   Click image for larger version

Name:	Screenshot_2014-06-29-15-25-24.png
Views:	79
Size:	85.3 KB
ID:	2823841  
29th June 2014, 10:27 PM   |  #4  
tys0n's Avatar
Recognized Contributor
Flag Stockholm
Thanks Meter: 1,256
 
1,982 posts
Join Date:Joined: Nov 2010
More
Quote:
Originally Posted by warezhafid14

Thx tyson.

Here's a screenshot of betterbatterystats

So, this tells me that your phone has been awake about 23 mins while your screen was off. To know why you have to look at kernel wakelocks, and then take it further depending on what that will show.
The Following User Says Thank You to tys0n For This Useful Post: [ View ]
2nd July 2014, 06:22 PM   |  #5  
warezhafid14's Avatar
OP Member
Thanks Meter: 0
 
34 posts
Join Date:Joined: Oct 2013
Quote:
Originally Posted by tys0n

So, this tells me that your phone has been awake about 23 mins while your screen was off. To know why you have to look at kernel wakelocks, and then take it further depending on what that will show.

Thank you tyson!

here's a screenshot of the kernel wakelocks
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-07-02-16-31-30.png
Views:	57
Size:	94.2 KB
ID:	2828946   Click image for larger version

Name:	Screenshot_2014-07-02-16-32-03.png
Views:	47
Size:	83.2 KB
ID:	2828947  
2nd July 2014, 07:24 PM   |  #6  
tys0n's Avatar
Recognized Contributor
Flag Stockholm
Thanks Meter: 1,256
 
1,982 posts
Join Date:Joined: Nov 2010
More
Quote:
Originally Posted by warezhafid14

Thank you tyson!

here's a screenshot of the kernel wakelocks

There we find that PowerManagerService.Wakelocks is at top, and this is usually a sum of all partial wakelocks.
Then we have to look at partial wakelocks to see why.
The Following User Says Thank You to tys0n For This Useful Post: [ View ]
3rd July 2014, 03:08 PM   |  #7  
warezhafid14's Avatar
OP Member
Thanks Meter: 0
 
34 posts
Join Date:Joined: Oct 2013
Quote:
Originally Posted by tys0n

There we find that PowerManagerService.Wakelocks is at top, and this is usually a sum of all partial wakelocks.
Then we have to look at partial wakelocks to see why.

Thx tyson.

here's partial wakelocks screenshot
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-07-03-14-04-59.png
Views:	46
Size:	112.5 KB
ID:	2830453   Click image for larger version

Name:	Screenshot_2014-07-03-14-05-17.png
Views:	39
Size:	131.5 KB
ID:	2830454  
3rd July 2014, 04:39 PM   |  #8  
GXGOW's Avatar
Senior Member
Flag /storage/sdcard1/Europe/Belgium/East-Flanders/Hamme
Thanks Meter: 176
 
618 posts
Join Date:Joined: Apr 2012
More
Quote:
Originally Posted by warezhafid14

Thx tyson.

here's partial wakelocks screenshot

Do you have location reporting turned off? You can check it in Settings - Location - Google Location Reporting.
The Following User Says Thank You to GXGOW For This Useful Post: [ View ]
3rd July 2014, 05:33 PM   |  #9  
warezhafid14's Avatar
OP Member
Thanks Meter: 0
 
34 posts
Join Date:Joined: Oct 2013
Quote:
Originally Posted by GXGOW

Do you have location reporting turned off? You can check it in Settings - Location - Google Location Reporting.

it was turned on
3rd July 2014, 07:28 PM   |  #10  
mauam's Avatar
Senior Member
Thanks Meter: 6,992
 
4,478 posts
Join Date:Joined: Jan 2011
More
Quote:
Originally Posted by warezhafid14

it was turned on

So turn it off. "scanning always available" option (in wifi settings) drains a lot.

The Following User Says Thank You to mauam For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes