Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Thread Closed

Needing help with Samsung Galaxy Y GT-S5360

OP IcarusRaptis

28th June 2014, 02:00 PM   |  #1  
OP Junior Member
Flag Laguna
Thanks Meter: 0
 
4 posts
Join Date:Joined: Jun 2014
More
Model: Samsung Galaxy Y GT-S5360

Running Custom: Hyperion 9 GM Final Build Final Rev + Update-01

Situation: So I've successfully flashed the new ROM a week ago. It was great, I must say, I really loved it. But yesterday, when I was on my way home, I found out that the phone wasn't starting up, even after I held the power button for more than 10 seconds.

I assumed that maybe the battery got drained, so I charged it as soon as I got home. The problem is, it's not charging. I even left it overnight to charge only to discover that it didn't.

I tried three different chargers and I even tried charging it by connecting it to my laptop but none of it worked.

I tried pressing the Volume Up+Menu Key+Power Button but to no avail. I can't even access the Download mode.

I can't open nor charge my phone and the buttons give no response at all.

So, any idea what the problem might be?

P.S.: I just joined today so if I broke some rule/s, kindly inform me so I could apologize and fix my mistake.
Last edited by malybru; 29th June 2014 at 03:18 PM.
28th June 2014, 04:48 PM   |  #2  
Darth's Avatar
XDA: ASSIST
Recognized Contributor
Flag The boonies - southwest Ontario
Thanks Meter: 4,637
 
12,223 posts
Join Date:Joined: May 2011
More
Hi there!!

I suggest you ask in your devices Q&A section, where your question will be seen by those who know your phone best!

And try a different cable as well!

> Legacy & Low Activity Devices > Samsung Galaxy Y GT-S5360 > Galaxy Y GT-S5360 Q&A, Help & Troubleshooting

Good luck!! Hope you get it running!
29th June 2014, 01:35 AM   |  #3  
OP Junior Member
Flag Laguna
Thanks Meter: 0
 
4 posts
Join Date:Joined: Jun 2014
More
Quote:
Originally Posted by KJ

Hi there!!

I suggest you ask in your devices Q&A section, where your question will be seen by those who know your phone best!

And try a different cable as well!

> Legacy & Low Activity Devices > Samsung Galaxy Y GT-S5360 > Galaxy Y GT-S5360 Q&A, Help & Troubleshooting

Good luck!! Hope you get it running!

Okay, will do. Thanks.
Thread Closed Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes