Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,741,151 Members 51,098 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Eclipse issues - rebooting and installing apps

Tip us?
 
C3PH0
Old
(Last edited by C3PH0; 28th June 2014 at 05:57 PM.)
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Jun 2014
Unhappy [Q] Eclipse issues - rebooting and installing apps

TL;DR - Installed bean's rooted kit kat, new safestrap, and Eclipse ROM 2.0.1. Phone essentially freezes when prompted to shut off or reboot and gets stuck there indefinitely. I also cannot install any apps via the play store reliably from Eclipse.


Hello everyone! I'm fairly new to rooting/flashing roms, and last night I used Bean's rooted kit kat to upgrade my N3 from 4.3 to 4.4. I went with de-odexed because from what I understood it was easier to change themes and whatnot that way (again, forgive me if I'm wrong, still new to all of this). Everything went great, I installed to stock rom slot, Odin detected my phone in DL mode, I installed the new firmware, it updated and loaded all the apps just fine, and I installed the new safestrap.

There was a problem however... Whenever I go to turn off or reboot the phone, the "shutting down" dialogue box comes up and it just gets stuck there. I timed it for about 20 minutes before finally just pulling the battery. It does this everytime I need to reboot the phone and I always have to end up pulling the battery.

EDIT: As of this morning the stock rom appears to no longer be having the reboot issue. My guess is that is just a bug in a Eclipse at this point.

Thinking it might be just a weird bug, I made a partition in ROM slot 2 (ROM slot 1 was where my 4.3 was and I hadn't deleted it yet) and installed Eclipse 2.0.1. When I booted into it and logged into my Google account to recover all my apps like I did just did with the stock rom slot, all the apps que'd up, but nothing showed as installing. I thought that maybe I had kinda just overwhelmed the phone with downloads and went into the play store to stop the que. I started installing about 3 apps at a time to see if it worked better, and I ran into the same issue. Usually when you click "install" on an app, it will show the download process and then start installing to your phone. Mine goes straight to install and gets stuck on an endless loading bar, with no way to cancel or stop it without a reboot.

Rebooting is also having the same issue as before. I cannot shut off or restart the device without it locking into the shutting down dialogue box.


1. Did installing a de-odexed version cause any problems that I wouldn't have had with an odexed?
2. If so, I can follow the same methods I did to install bean's kit kat and reinstall the odexed version? Or would I have to somehow go back to 4.3 first?
3. Are there any other known fixes I should try?
 
Harleydroid
Old
(Last edited by Harleydroid; 29th June 2014 at 01:02 AM.)
#2  
Harleydroid's Avatar
Senior Member
Thanks Meter 563
Posts: 1,374
Join Date: Jul 2013
Location: The Fort
Quote:
Originally Posted by C3PH0 View Post
TL;DR - Installed bean's rooted kit kat, new safestrap, and Eclipse ROM 2.0.1. Phone essentially freezes when prompted to shut off or reboot and gets stuck there indefinitely. I also cannot install any apps via the play store reliably from Eclipse.


Hello everyone! I'm fairly new to rooting/flashing roms, and last night I used Bean's rooted kit kat to upgrade my N3 from 4.3 to 4.4. I went with de-odexed because from what I understood it was easier to change themes and whatnot that way (again, forgive me if I'm wrong, still new to all of this). Everything went great, I installed to stock rom slot, Odin detected my phone in DL mode, I installed the new firmware, it updated and loaded all the apps just fine, and I installed the new safestrap.

There was a problem however... Whenever I go to turn off or reboot the phone, the "shutting down" dialogue box comes up and it just gets stuck there. I timed it for about 20 minutes before finally just pulling the battery. It does this everytime I need to reboot the phone and I always have to end up pulling the battery.

EDIT: As of this morning the stock rom appears to no longer be having the reboot issue. My guess is that is just a bug in a Eclipse at this point.

Thinking it might be just a weird bug, I made a partition in ROM slot 2 (ROM slot 1 was where my 4.3 was and I hadn't deleted it yet) and installed Eclipse 2.0.1. When I booted into it and logged into my Google account to recover all my apps like I did just did with the stock rom slot, all the apps que'd up, but nothing showed as installing. I thought that maybe I had kinda just overwhelmed the phone with downloads and went into the play store to stop the que. I started installing about 3 apps at a time to see if it worked better, and I ran into the same issue. Usually when you click "install" on an app, it will show the download process and then start installing to your phone. Mine goes straight to install and gets stuck on an endless loading bar, with no way to cancel or stop it without a reboot.

Rebooting is also having the same issue as before. I cannot shut off or restart the device without it locking into the shutting down dialogue box.


1. Did installing a de-odexed version cause any problems that I wouldn't have had with an odexed?
2. If so, I can follow the same methods I did to install bean's kit kat and reinstall the odexed version? Or would I have to somehow go back to 4.3 first?
3. Are there any other known fixes I should try?
I read your post a couple times and I think you may be using the wrong Safestrap. I could be wrong.
Use stable Safestrap 3.65 for jellybean roms and Safestrap 3.72 or 3.75 for nc2/nc4 roms.
I'm running Eclipse 2.0.1 on Safestrap 3.75 right now and have zero reboot problems.


Sent from my Eclipsed Note 3 using XDA Premium
The Following User Says Thank You to Harleydroid For This Useful Post: [ Click to Expand ]
 
C3PH0
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Jun 2014
Quote:
Originally Posted by Harleydroid View Post
I read your post a couple times and I think you may be using the wrong Safestrap. I could be wrong.
Use stable Safestrap 3.65 for jellybean roms and Safestrap 3.72 or 3.75 for nc2/nc4 roms.
I'm running Eclipse 2.0.1 on Safestrap 3.75 right now and have zero reboot problems.


Sent from my Eclipsed Note 3 using XDA Premium
Yup! This was it. I installed 3.75 and re-flashed. I feel slightly dumb for not thinking of that but I'm so happy to have a functional phone again. Thank you very much!
 
Harleydroid
Old
#4  
Harleydroid's Avatar
Senior Member
Thanks Meter 563
Posts: 1,374
Join Date: Jul 2013
Location: The Fort
Quote:
Originally Posted by C3PH0 View Post
Yup! This was it. I installed 3.75 and re-flashed. I feel slightly dumb for not thinking of that but I'm so happy to have a functional phone again. Thank you very much!
You bet bud

Sent from my Eclipsed Note 3 using XDA Premium
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes