Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,741,401 Members 39,029 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Charging issue

Tip us?
 
ikoniq
Old
#1  
ikoniq's Avatar
Member - OP
Thanks Meter 3
Posts: 39
Join Date: Jan 2012
Location: Omaha, NE

 
DONATE TO ME
Default [Q] Charging issue

I'm absolutely freaking baffled. Simply put, my Atrix HD doesn't charge if it's powered on. At all. It doesn't even recognize that it's plugged into a power source. As soon as I turn it off, the little green light at the top lights up. I need help, this is infuriating me.
 
mrao
Old
#2  
mrao's Avatar
Senior Member
Thanks Meter 20
Posts: 210
Join Date: Dec 2005
Location: Mumbai

 
DONATE TO ME
Have you tried a different charging cable... Or plugging it into the USB port on a PC while the phone is on? If it still displays these symptoms, it's possible the micro USB connector on the phone is messed up
 
ikoniq
Old
#3  
ikoniq's Avatar
Member - OP
Thanks Meter 3
Posts: 39
Join Date: Jan 2012
Location: Omaha, NE

 
DONATE TO ME
Quote:
Originally Posted by mrao View Post
Have you tried a different charging cable... Or plugging it into the USB port on a PC while the phone is on? If it still displays these symptoms, it's possible the micro USB connector on the phone is messed up
I am now realizing I should have gone into more detail about the issue. I went to plug it in today, and it wouldn't charge. It was running the latest Milestone build of CM11. I went ahead and tried to turn it off and back on, and it started boot looping. I managed to get it into AP Fastboot and fastboot-flashed it back to stock. It has an unlocked bootloader. So now I'm on stock Android 4.1.1, and boot looping with the battery below ten percent. Above ten percent, it stops looping and just kind of sits there, but will boot up fine. Once I get it back into Android, it stops charging again. The issue persists no matter what cable/charger/PC combination I use. Since it charges fine in Fastboot, Recovery, and while off, and persists across multiple chargers and cords, the only idea I have is that it is a software issue in Android somewhere, I just can't figure out for the life of me where it might be.
 
Arjomer
Old
#4  
Arjomer's Avatar
Senior Member
Thanks Meter 16
Posts: 108
Join Date: Oct 2013
Quote:
Originally Posted by ikoniq View Post
I'm absolutely freaking baffled. Simply put, my Atrix HD doesn't charge if it's powered on. At all. It doesn't even recognize that it's plugged into a power source. As soon as I turn it off, the little green light at the top lights up. I need help, this is infuriating me.
Have you tried deleting battery stats?
 
ikoniq
Old
#5  
ikoniq's Avatar
Member - OP
Thanks Meter 3
Posts: 39
Join Date: Jan 2012
Location: Omaha, NE

 
DONATE TO ME
Quote:
Originally Posted by mrao View Post
Have you tried a different charging cable... Or plugging it into the USB port on a PC while the phone is on? If it still displays these symptoms, it's possible the micro USB connector on the phone is messed up
Quote:
Originally Posted by Arjomer View Post
Have you tried deleting battery stats?
Well now it won't boot at all, so it's a bit of a moot point.
 
ikoniq
Old
#6  
ikoniq's Avatar
Member - OP
Thanks Meter 3
Posts: 39
Join Date: Jan 2012
Location: Omaha, NE

 
DONATE TO ME
UPDATE: It's boot looping again, pretty sure that's it having a more or less dead battery tho. Woo!
 
mm166
Old
#7  
Senior Member
Thanks Meter 35
Posts: 121
Join Date: Oct 2011
Are you using original Motorola charger ? I've had problems with 3rd party chargers/cables with Atrix.
Atrix HD Maxx SIM, BL: Unlocked
Tab 2
Don't have dropbox account yet? Sing up here and we both will earn extra 500mb.
Need free antivirus for Windows? I suggest Avast.
Great game deals here. <--- Use that link and you will get free $2 after first purchase above 2$.
 
ikoniq
Old
(Last edited by ikoniq; 29th June 2014 at 07:44 PM.)
#8  
ikoniq's Avatar
Member - OP
Thanks Meter 3
Posts: 39
Join Date: Jan 2012
Location: Omaha, NE

 
DONATE TO ME
Quote:
Originally Posted by mm166 View Post
Are you using original Motorola charger ? I've had problems with 3rd party chargers/cables with Atrix.
Yeah, original Motorola charger.

Just a note, I can get it into fastboot, flash it, reboot it, and have it not boot loop for a few minutes, but as soon as the bootloader hands control off it stops charging...while it's in fastboot it seems to either be charging or running off USB.

Tags
android, charging
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Mod Lets You Have Stereo Speakers on Your Sony Xperia Z1 (Sort Of)

The stereo speakers onthe Sony Xperia Z2areprobably a relatively large … more

Give Your Screen Some Color with HexaTime Live Wallpaper

We don’t often cover very many live wallpapers here on the XDA Portal. You may … more

Android Wear App Review: Command Google Now with Commandr – XDA Developer TV

OK Google. Make Me a sandwich. How many times have you … more

Play Your Hits and Learn the Lyrics with NextGen Music Player

There are plenty of music players for Android available in Play Store. They … more