Post Reply

[Q] Xperia Play R800i automatically reboot whenever wifi is turned on

OP kukuru

30th June 2014, 02:50 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: Jul 2012
Hi guys, I am helping to fix my lil bro's r800i.

His phone keeps restarting whenever I turn the wifi on and there is no phone signal. I mean visually the signal bar is there but no calling or checking credit balance could be done.

This happened since he did software update from sony's end to R800i_4.0.2.A.0.42.
Upon lurking xda, I found out these problems may be caused by the baseband.

Therefore I used flashtool to flash:
> R800i_4.0.A.2.368_World
>R800i_4_0_2_A_0_69_WORLD_1_8_1247_6176
>R800_4.0.2.A.0.79
>X10_V1_BLRelock
>and one other custom rom called GB something


I also tried to flash new kernel:
>LuPuS_zeus_Stock-gB+iCsv7-full
>PLAY-GSM-Advanced-Stock-vt
>ExtremeKernel_r3-480p

note: I wanted to try doomkernel but I couldnt find working download link

Other than that, I tried to flash only the baseband:
>Baseband -36

However, I couldn't solve the problems with the previous steps. I need advice from experienced users, thank you guys..
30th June 2014, 06:25 AM   |  #2  
Bakisha's Avatar
Senior Member
Thanks Meter: 483
 
890 posts
Join Date:Joined: May 2011
More
Try phone without sim or with different sim card
Do you know what firmware version was before you update it to .42?
You did right thing with flashing different basebands, but maybe it's hardware fault...
Maybe to try with lowest firmware version you can find?

Sent from my C6502 using XDA Free mobile app
The Following User Says Thank You to Bakisha For This Useful Post: [ View ]
30th June 2014, 06:31 AM   |  #3  
OP Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: Jul 2012
Quote:
Originally Posted by Bakisha

Try phone without sim or with different sim card
Do you know what firmware version was before you update it to .42?
You did right thing with flashing different basebands, but maybe it's hardware fault...
Maybe to try with lowest firmware version you can find?

Sent from my C6502 using XDA Free mobile app

The sim card is working well in other mobile phone.
So the wifi and signal uses the same hardware?

I will try your suggestion on the lowest firmware flashing and update later on. Thank you Bakisha.
30th June 2014, 06:52 AM   |  #4  
Bakisha's Avatar
Senior Member
Thanks Meter: 483
 
890 posts
Join Date:Joined: May 2011
More
Quote:
Originally Posted by kukuru

The sim card is working well in other mobile phone.
So the wifi and signal uses the same hardware?

I will try your suggestion on the lowest firmware flashing and update later on. Thank you Bakisha.

As i know, wifi and network hardware is not related in hardware terms (but i'm not sure)
Also, try wifi in airplane mode (to see is it single or two separate problems)

Sent from my C6502 using XDA Free mobile app
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes