Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,738,692 Members 40,454 Now Online
XDA Developers Android and Mobile Development Forum

RK3066 (MK802 III) Flashtool and Android 4.4.2

Tip us?
 
mistersixt
Old
#1  
Senior Member - OP
Thanks Meter 53
Posts: 113
Join Date: Jun 2011
Default RK3066 (MK802 III) Flashtool and Android 4.4.2

Recently I found this interesting Tool ... and I successfully flashed "Allminipc_ug802_RT8188_4.4_720p.img" (Kitkat version) on my MK802 III using Debian Linux 7.5!

Regards, mistersixt.
History: bravo --> jordan --> p4 --> maguro --> u8800 --> i9300 --> mako --> rk3066 --> v500
The Following User Says Thank You to mistersixt For This Useful Post: [ Click to Expand ]
 
mistersixt
Old
#2  
Senior Member - OP
Thanks Meter 53
Posts: 113
Join Date: Jun 2011
In case someone is interested: I successfully installed the rk3066 drivers for WinXP using Moborobo, rooted the device with the kingo root tool, and I was able to installed the xposed framework 2.6, too, including XPrivacy, root cloak etc.

So I have a fully 4.4.2 running MK802 III with root access and Xposed framework!

Regards, mistersixt.
History: bravo --> jordan --> p4 --> maguro --> u8800 --> i9300 --> mako --> rk3066 --> v500
The Following User Says Thank You to mistersixt For This Useful Post: [ Click to Expand ]
 
optimus975
Old
#3  
Member
Thanks Meter 13
Posts: 78
Join Date: Mar 2014
Quote:
Originally Posted by mistersixt View Post
Recently I found this interesting Tool ... and I successfully flashed "Allminipc_ug802_RT8188_4.4_720p.img" (Kitkat version) on my MK802 III using Debian Linux 7.5!

Regards, mistersixt.

Very interesting..Any chance you could share the firmware image file and also let us know how has it been so far...is it fast enough and does the Wifi and Camera (UVC drivers compatible) work w/ this ?

Also could you confirm if this is for MK802III and not MK802IIIS...

Cheers
 
mistersixt
Old
#4  
Senior Member - OP
Thanks Meter 53
Posts: 113
Join Date: Jun 2011
Quote:
Originally Posted by optimus975 View Post
Very interesting..Any chance you could share the firmware image file and also let us know how has it been so far...is it fast enough and does the Wifi and Camera (UVC drivers compatible) work w/ this ?

Also could you confirm if this is for MK802III and not MK802IIIS...

Cheers

It is the MK802III, and the stick is running fast and stable. Wifi is as bad as with 4.1 ... but I think this is a general (or hardware related) issue, I am using it with a USB to LAN adapter anyway.

Concerning the camera I have no idea.

Regards, mistersixt.
History: bravo --> jordan --> p4 --> maguro --> u8800 --> i9300 --> mako --> rk3066 --> v500
 
optimus975
Old
#5  
Member
Thanks Meter 13
Posts: 78
Join Date: Mar 2014
Quote:
Originally Posted by mistersixt View Post
It is the MK802III, and the stick is running fast and stable. Wifi is as bad as with 4.1 ... but I think this is a general (or hardware related) issue, I am using it with a USB to LAN adapter anyway.

Concerning the camera I have no idea.

Regards, mistersixt.
Hi,

Thanks for your response.

I've just installed this firmware on my MK802III and it seems no audio video app is working properly. Youtube does not show any video or sound. Neither can I play youtube in the browser.

No streaming media player works either. Only the local media files are playing properly.

The playstore seems to take ages to install apps because of speed, however when I check the internet speed using speed testing app it gives a good enough speed of 7Mbps.

Also i've noticed that there the wifi network connections are getting dropped abruptly. The wifi connection itself seems to be OK but connection from apps such as Airdroid drop out and upload from my local machine via Airdroid takes ages w/ speeds in Kbps.

Can this be fixed please.

Thanks,
OP
 
optimus975
Old
#6  
Member
Thanks Meter 13
Posts: 78
Join Date: Mar 2014
Quote:
Originally Posted by optimus975 View Post
Hi,

Thanks for your response.

I've just installed this firmware on my MK802III and it seems no audio video app is working properly. Youtube does not show any video or sound. Neither can I play youtube in the browser.

No streaming media player works either. Only the local media files are playing properly.

The playstore seems to take ages to install apps because of speed, however when I check the internet speed using speed testing app it gives a good enough speed of 7Mbps.

Also i've noticed that there the wifi network connections are getting dropped abruptly. The wifi connection itself seems to be OK but connection from apps such as Airdroid drop out and upload from my local machine via Airdroid takes ages w/ speeds in Kbps.

Can this be fixed please.

Thanks,
OP
bumping this up..!
 
WildeRNS
Old
#7  
WildeRNS's Avatar
Senior Member
Thanks Meter 28
Posts: 134
Join Date: Sep 2009
can confirm, that works great on Measy U2A.
Dell Venue Pro

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Browse the Internet with the Innovative Atlas Web Browser

For the most part, Chrome, Firefox, and Dolphin Browser have no real rivals among … more

Choose from Over a Thousand Battery Styles with 3Minit Battery Mod

The battery style in stock Android looks pretty dull. It doesn’t … more

Organize Your Cloud Storage Files with Unclouded

Cloud storage services like Dropbox or Google Drive have grown in popularity dramatically … more

XDA Xposed Tuesday: Blur Your System Notification Panel – XDA Developer TV

Listen, we love innovative applications and modules that … more