5,815,095 Members 38,263 Now Online
XDA Developers Android and Mobile Development Forum

[Q] i9505 Only Charges when OFF

Tip us?
 
yurividal
Old
#1  
Senior Member - OP
Thanks Meter 21
Posts: 209
Join Date: May 2008
Location: Rio de Janeiro
Plug [Q] i9505 Only Charges when OFF

Hey guys, since yesterday, my i9505 only charges when it is off.

When it is on, nothing happens. When it is on, if i connect the USB to the PC it also does not charge nor recognize any device (not even listed in "lsusb"). The connector is fine, because when i connect a USB OTG cable, and a USB stick, it mounts normally.

Also, from recovery and from Download mode, i am able to use USB cable connected to pc. So, problem is not with the connector.

I have flashed back to Stock, un-rooted, from ODIN. Still does not charge when is on.

It only charges when the phone is off. (Shows the battery icon, with a circle in the middle).

Also, i have tried annother battery too, and different chargers.

Any ideas?

Does not seem to be battery, does not seem to be software, does not seem to be connector, and does not seem to be charger.
Phone: Samsung Galaxy S4 i9505
Carrier: Vivo Brasil
Rom: Carbon Rom AOSP Android KitKat 4.4.4 (Latest Nightly)
Recovery: Openrecovery - TWRP - 2.7.0.1
Baseband: I9505XXUFNA5
Kernel: 3.4.0-cyanogenmod
 
yurividal
Old
#2  
Senior Member - OP
Thanks Meter 21
Posts: 209
Join Date: May 2008
Location: Rio de Janeiro
obs: it charges when in recovery. (TWRP)
Phone: Samsung Galaxy S4 i9505
Carrier: Vivo Brasil
Rom: Carbon Rom AOSP Android KitKat 4.4.4 (Latest Nightly)
Recovery: Openrecovery - TWRP - 2.7.0.1
Baseband: I9505XXUFNA5
Kernel: 3.4.0-cyanogenmod
 
m466e
Old
#3  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Nov 2010
I have the same problem. Got it when going from 4.2.2 stock to 4.4.2 Pac rom.
Going back to 4.2.2 stock did not solve the problem
Any ideas anybody?
 
ZenMax
Old
#4  
ZenMax's Avatar
Junior Member
Thanks Meter 0
Posts: 14
Join Date: Mar 2013
Location: Lithuania
Quote:
Originally Posted by yurividal View Post
Hey guys, since yesterday, my i9505 only charges when it is off.

When it is on, nothing happens. When it is on, if i connect the USB to the PC it also does not charge nor recognize any device (not even listed in "lsusb"). The connector is fine, because when i connect a USB OTG cable, and a USB stick, it mounts normally.

Also, from recovery and from Download mode, i am able to use USB cable connected to pc. So, problem is not with the connector.

I have flashed back to Stock, un-rooted, from ODIN. Still does not charge when is on.

It only charges when the phone is off. (Shows the battery icon, with a circle in the middle).

Also, i have tried annother battery too, and different chargers.

Any ideas?

Does not seem to be battery, does not seem to be software, does not seem to be connector, and does not seem to be charger.



Mine was doing the same I changed charging port on my s4 and problem was solved
 
yurividal
Old
(Last edited by yurividal; 30th June 2014 at 02:07 PM.)
#5  
Senior Member - OP
Thanks Meter 21
Posts: 209
Join Date: May 2008
Location: Rio de Janeiro
Yeap!

I changed the charging port too, and it solved.
It was actually very easy to change. I bought the part, and watched a Youtube video showing how to open the device..

Very strange, that it charged when the phone was off..

anyways,

it solved. I noticed that my original OEM charger with original OEM cable is only charging the phone with max 480mA... while, when i use my Tablet charger it charges up to 1500mA...

I know it should be going up to 1900mA or even 2A... but, it is not happening.

Maybe my charger is also faulty
...

at least it is charging now... =D
Phone: Samsung Galaxy S4 i9505
Carrier: Vivo Brasil
Rom: Carbon Rom AOSP Android KitKat 4.4.4 (Latest Nightly)
Recovery: Openrecovery - TWRP - 2.7.0.1
Baseband: I9505XXUFNA5
Kernel: 3.4.0-cyanogenmod
 
yurividal
Old
(Last edited by yurividal; 30th June 2014 at 02:17 PM.)
#6  
Senior Member - OP
Thanks Meter 21
Posts: 209
Join Date: May 2008
Location: Rio de Janeiro
Quote:
Originally Posted by m466e View Post
I have the same problem. Got it when going from 4.2.2 stock to 4.4.2 Pac rom.
Going back to 4.2.2 stock did not solve the problem
Any ideas anybody?
maybe it is a coincidence... try changing the port. If you have no warranty (like me), buy the part online and change it... it is easy. https://www.youtube.com/watch?v=WCJcBltgE-I
If you are not corfortable, take it to some repair shop
Phone: Samsung Galaxy S4 i9505
Carrier: Vivo Brasil
Rom: Carbon Rom AOSP Android KitKat 4.4.4 (Latest Nightly)
Recovery: Openrecovery - TWRP - 2.7.0.1
Baseband: I9505XXUFNA5
Kernel: 3.4.0-cyanogenmod
Tags
battery charging issue help
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Change the Style of Your Notifications with HeadsUp

Head Up notifications is one of these upcoming features that Android developers hid deep … more

Google Play Store to Show Price Ranges for In-App Purchases

Google recently announced a change to Google Play Store policy that requires … more

XDA Xposed Tuesday: How to Shut Up Your Phone – XDA Developer TV

So many different applications want to send us notifications that … more

Add Some Power to First Generation Snapdragon CPUs

Some older devices still remain very popular. Phones like theHTC Desire, Sony Ericsson … more