FORUMS

Android 5.1 for the Nvidia Shield Tablet is Out!

Nvidia is quite good at delivering updates in a timely fashion. The producer of famous … more

Other than XDA (of Course), What’s Your Favorite Site That Covers Android?

There is a number of other great sites that cover … more

Introducing Voices of XDA: Have Your Ideas Heard

By far the greatest assets we have at XDA-Developers are you, the developers, the eager … more

Unofficial Xposed For Lollipop Touchwiz With Flashable Zip

XDA Recognized Developer arter97 has released an unofficial build … more
Post Reply Subscribe to Thread Email Thread

[Q] i9505 Only Charges when OFF

23rd June 2014, 12:39 AM |#1  
OP Senior Member
Flag Rio de Janeiro
Thanks Meter: 158
 
More
Hey guys, since yesterday, my i9505 only charges when it is off.

When it is on, nothing happens. When it is on, if i connect the USB to the PC it also does not charge nor recognize any device (not even listed in "lsusb"). The connector is fine, because when i connect a USB OTG cable, and a USB stick, it mounts normally.

Also, from recovery and from Download mode, i am able to use USB cable connected to pc. So, problem is not with the connector.

I have flashed back to Stock, un-rooted, from ODIN. Still does not charge when is on.

It only charges when the phone is off. (Shows the battery icon, with a circle in the middle).

Also, i have tried annother battery too, and different chargers.

Any ideas?

Does not seem to be battery, does not seem to be software, does not seem to be connector, and does not seem to be charger.
 
 
23rd June 2014, 12:38 PM |#2  
OP Senior Member
Flag Rio de Janeiro
Thanks Meter: 158
 
More
obs: it charges when in recovery. (TWRP)
29th June 2014, 11:46 PM |#3  
Junior Member
Thanks Meter: 0
 
More
I have the same problem. Got it when going from 4.2.2 stock to 4.4.2 Pac rom.
Going back to 4.2.2 stock did not solve the problem
Any ideas anybody?
30th June 2014, 07:40 AM |#4  
Quote:
Originally Posted by yurividal

Hey guys, since yesterday, my i9505 only charges when it is off.

When it is on, nothing happens. When it is on, if i connect the USB to the PC it also does not charge nor recognize any device (not even listed in "lsusb"). The connector is fine, because when i connect a USB OTG cable, and a USB stick, it mounts normally.

Also, from recovery and from Download mode, i am able to use USB cable connected to pc. So, problem is not with the connector.

I have flashed back to Stock, un-rooted, from ODIN. Still does not charge when is on.

It only charges when the phone is off. (Shows the battery icon, with a circle in the middle).

Also, i have tried annother battery too, and different chargers.

Any ideas?

Does not seem to be battery, does not seem to be software, does not seem to be connector, and does not seem to be charger.




Mine was doing the same I changed charging port on my s4 and problem was solved
30th June 2014, 02:03 PM |#5  
OP Senior Member
Flag Rio de Janeiro
Thanks Meter: 158
 
More
Yeap!

I changed the charging port too, and it solved.
It was actually very easy to change. I bought the part, and watched a Youtube video showing how to open the device..

Very strange, that it charged when the phone was off..

anyways,

it solved. I noticed that my original OEM charger with original OEM cable is only charging the phone with max 480mA... while, when i use my Tablet charger it charges up to 1500mA...

I know it should be going up to 1900mA or even 2A... but, it is not happening.

Maybe my charger is also faulty
...

at least it is charging now... =D
Last edited by yurividal; 30th June 2014 at 02:07 PM.
30th June 2014, 02:05 PM |#6  
OP Senior Member
Flag Rio de Janeiro
Thanks Meter: 158
 
More
Quote:
Originally Posted by m466e

I have the same problem. Got it when going from 4.2.2 stock to 4.4.2 Pac rom.
Going back to 4.2.2 stock did not solve the problem
Any ideas anybody?

maybe it is a coincidence... try changing the port. If you have no warranty (like me), buy the part online and change it... it is easy. https://www.youtube.com/watch?v=WCJcBltgE-I
If you are not corfortable, take it to some repair shop
Last edited by yurividal; 30th June 2014 at 02:17 PM.
Post Reply Subscribe to Thread

Tags
battery charging issue help
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes