Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,732,619 Members 52,290 Now Online
XDA Developers Android and Mobile Development Forum

[Q] wifi problem

Tip us?
 
arash.mid
Old
(Last edited by arash.mid; 29th June 2014 at 04:57 AM.)
#1  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Jun 2014
Question [Q] wifi problem

hi. i have wifi issue with my z2. sometimes it does not connect and just says "saved.scured with wpa" but sometimes it connects but wont work! i mean i can not open any web pages with browsers. sometimes else it connects but internet speed is very slow . i don't have this problems with my ex phone xperia s. please help me with this and sorry for my english!
 
Envious_Data
Old
#2  
Envious_Data's Avatar
Senior Member
Thanks Meter 667
Posts: 1,625
Join Date: Oct 2012
Location: Yaizu
Try forgetting network then reconnecting, see if the problem is still there

If the problem is still thereReflash your firmware via flashtool or repair via PC companion

If the problem is still there, return your device for a replacement

Sent from my D6503 using XDA Premium 4 mobile app
Devices:
Sony Xperia Z2

Roms:
Envi-Rom Z2/S
The Following User Says Thank You to Envious_Data For This Useful Post: [ Click to Expand ]
 
arash.mid
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Jun 2014
Quote:
Originally Posted by Envious_Data View Post
Try forgetting network then reconnecting, see if the problem is still there

If the problem is still thereReflash your firmware via flashtool or repair via PC companion

If the problem is still there, return your device for a replacement

Sent from my D6503 using XDA Premium 4 mobile app
how can i repair via pc companion?
 
Envious_Data
Old
#4  
Envious_Data's Avatar
Senior Member
Thanks Meter 667
Posts: 1,625
Join Date: Oct 2012
Location: Yaizu
Quote:
Originally Posted by arash.mid View Post
how can i repair via pc companion?
In sony PC companion there is a repair device option in support zone, simply folow the instruction it gives

Sent from my D6503 using XDA Premium 4 mobile app
Devices:
Sony Xperia Z2

Roms:
Envi-Rom Z2/S
 
Einride
Old
#5  
Einride's Avatar
Senior Member
Thanks Meter 104
Posts: 345
Join Date: Sep 2010

 
DONATE TO ME
Sounds like the same issue me and others are experiencing with 2.4 GHz networks: http://forum.xda-developers.com/show....php?t=2795344.

Hopefully it's just a driver issue and a future software update will fix it. I can manage for now, I've got 5 GHz APs at work and home, and that works fine. A temporary workaround is disabling Bluetooth if you don't use it, and then reboot your phone. That fixed the problem in my case, at least for a while (but I need Bluetooth for the car and the Smartband).
Lay down your soul to the Gods rock n roll!
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes