Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,743,150 Members 44,296 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Gyro Not Working

Tip us?
 
bad x boy
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 14
Join Date: Jun 2011
Default [Q] Gyro Not Working

Hello,

So as the title says, my gyroscope isn't working.
I haven't tried it on ColorOS, Google Camera doesn't install there, other ROMs like cm11, PA, and Gummy either crash when I go into panorama/photo sphere modes or they just not function properly.
However, games seem to work just fine, probably because they use the accelerometer sensor.
I've downloaded this app to test whether it's working at all or not, seems to be working, not fully, but partially; moves at the right direction, but not with the same amount.
Currently running cm11-20140626.

Any help is appreciated.
Thanks.
 
andriman
Old
#2  
Member
Thanks Meter 15
Posts: 57
Join Date: Feb 2013
Google Camera doesn't work on ColorOS?
I beg to differ:
http://www.oppoforums.com/threads/go...find-7a.16117/

I can even use the photosphere with no problem...
 
bad x boy
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 14
Join Date: Jun 2011
Ah, well, I'll try that, flashing ColorOS. Thanks!
 
Entropy512
Old
#4  
Senior Recognized Developer
Thanks Meter 24128
Posts: 13,144
Join Date: Aug 2007
Location: Owego, NY

 
DONATE TO ME
your gyro works fine.

If you're talking about photosphere, it's the magnetometer that's derping, and it only derps in photosphere. No one has had time to track down why yet.
*so much sig updating needed*

My Github profile - Some Android stuff, some AVR stuff

An excellent post on "noobs vs. developers"

A few opinions on kernel development "good practices"

Note: I have chosen not to use XDA's "friends" feature - I will reject all incoming "friend" requests.

Code:
<MikeyMike01> Smali is a spawn of hell
<shoman94> ^^^ +!
Code:
<Entropy512> gotta be careful not to step on each other's work.  :)
<Bumble-Bee> thats true
<jerdog> compeete for donations
 
bad x boy
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 14
Join Date: Jun 2011
I tried install that "camera" app on cm11, it doesn't even install.
Flashed ColorOS, downloaded an app that uses the gyro, works just fine, I guess the problem was with all the custom ROMs I was getting.
The main reason I changed from ColorOS is that it doesn't have the "hold back button to kill" function, seems like I'll be using xposed now.

Thanks to everyone.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes