Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Accidentally removed bluetooth.apk--bt won't work after restore

OP elempoimen

30th June 2014, 05:58 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
15 posts
Join Date:Joined: Sep 2006
More
So I accidentally removed bluetooth.apk while debloating my phone with Titanium Backup. When I restored the backup, it will not work--not even to start bluetooth. It just crashes whenever I try to turn it on.

I removed a lot of other stuff too...all was supposed to be safe. Does bluetooth.apk depend on something else I have removed?

Sent from my SCH-I535 using XDA Free mobile app
30th June 2014, 01:04 PM   |  #2  
Sandman-007's Avatar
Recognized Contributor
Flag Newnan
Thanks Meter: 1,958
 
2,810 posts
Join Date:Joined: Sep 2012
More
Quote:
Originally Posted by elempoimen

So I accidentally removed bluetooth.apk while debloating my phone with Titanium Backup. When I restored the backup, it will not work--not even to start bluetooth. It just crashes whenever I try to turn it on.

I removed a lot of other stuff too...all was supposed to be safe. Does bluetooth.apk depend on something else I have removed?

Sent from my SCH-I535 using XDA Free mobile app

After restoring Bluetooth.apk wipe data for that app. Then reboot.

Sent from my SCH-I535 using Tapatalk
30th June 2014, 01:52 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
15 posts
Join Date:Joined: Sep 2006
More
Thanks, but it doesn't work. "Unfortunately, bluetooth share has stopped." I get the error as soon as I unlock the screen, and also when I try to turn it on.

Sent from my SCH-I535 using XDA Free mobile app
1st July 2014, 12:19 AM   |  #4  
Sandman-007's Avatar
Recognized Contributor
Flag Newnan
Thanks Meter: 1,958
 
2,810 posts
Join Date:Joined: Sep 2012
More
People on the VZW forums are saying its a 4.3 issue and going to 4.4.2 solves the problem

Sent from my SCH-I535 using Tapatalk

---------- Post added at 06:14 PM ---------- Previous post was at 06:02 PM ----------

Also try the BLE Crash Resolver app from the play store. Not a complete fix but will help

Sent from my SCH-I535 using Tapatalk

---------- Post added at 06:19 PM ---------- Previous post was at 06:14 PM ----------

http://www.androidpolice.com/2014/05...elly-bean-4-3/

Sent from my SCH-I535 using Tapatalk
1st July 2014, 12:39 AM   |  #5  
OP Junior Member
Thanks Meter: 0
 
15 posts
Join Date:Joined: Sep 2006
More
It worked perfectly before I inadvertently removed the file. :/

The BLE Crash Resolver doesn't work, because I cant even get BT to start.

I think I may try to flash dirty tonight and see if I can resolve it.

Sent from my SCH-I535 using XDA Free mobile app
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes