Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,732,170 Members 43,458 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Exynos KitKat Battery Drain - gpsd & l2_hsic

Tip us?
 
ironique
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Jan 2012
Location: Nairobi
Default [Q] Exynos KitKat Battery Drain - gpsd & l2_hsic

Hi Guys,

I upgraded my Exynos Note 3 to Kitkat about 1 month ago, and everything was fine till about 3 days ago when I started experiencing some really bad battery drain. For the last three nights, my phone does not go into deep sleep mode at all. I first noticed this because I usually switch off data and wifi at night. Normally, I'd loose 3% battery overnight, which is good. About two nights ago, I woke up in the morning and I had lost 40% battery (90% down to 50%) overnight! When I checked out the battery stats, "gpsd" had used 80% of the battery.

Since we no longer have batterystats access in Kitkat, I installed the desktop version of WakeLock Detector, enabled USB debugging mode and connected my phone. Phone had basically been awake 97% of the time. Under kernel wakelocks, "l2_hsic" was shown as being the culprit. Now I have searched through various forums online (including xda) to try and find a solution to this. Suggestions vary from home screen replacements (nova launcher) to mobile tracking software (cerberus/findmymobile etc) to generally anything that uses location services. Some even suggest clearing application caches, disabling location services etc. I have tried every suggestion with no change. I uninstalled all mobile tracking apps, turned off location reporting, location history, and eventually location services. I've removed all battery stats apps. I uninstalled all my apps and re-installed them one by one, all with no change. Finally, I backed up my phone and did a factory reset. That seemed to work at first, but after about 3 minutes, "gpsd" was back again, and my phone would not go into deep sleep.

I've done 3 factory resets, and with no google account or samsung account configured, I still get "gpsd" rearing it's ugly head, preventing the phone from going to deep sleep and draining my battery. I'm at wits end.

Anyone know how to fix this? Would appreciate any help!
 
ironique
Old
#2  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Jan 2012
Location: Nairobi
Anyone!?
 
ironique
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Jan 2012
Location: Nairobi
OK, so I decided to take out my SIM card, just to see it'd make a difference, and what do you know! "gpsd" no longer takes up CPU time! So this is somehow related to my SIM card? Funny though, coz I'd even tried putting the phone in Airplane mode, but "gpsd" was still taking up CPU time. Does that give anyone an idea as to how this can be fixed?
 
ironique
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Jan 2012
Location: Nairobi
bump
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes