Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Home button doesn't run launcher any more :/

OP Stasheck

26th June 2014, 04:15 PM   |  #1  
OP Junior Member
Thanks Meter: 1
 
29 posts
Join Date:Joined: Oct 2008
Hi all,
My phone rebooted and I lost all custom settings (like text size, custom ringtone etc.), while retaining other apps data. This was simple to repair

Problem is, since then my "Home" button doesn't execute launcher anymore. If I long-press, it shows tasks list, so the button is working, but short press does.. nothing.

I installed Home2 Shortcut - doesn't work either.
Cleared TouchWiz settings - no change
Cleared "Application preferences" - no change
Installed Nova Launcher - works fine, but won't return to home screen on "Home" press.

I guess some simple setting got corrupted, but I've no idea where to look for that. I'd rather not reflash the phone just because of this one button, but it's quite nice to be able to go to Home screen

Any advice?
26th June 2014, 04:33 PM   |  #2  
Joku1981's Avatar
Senior Member
Thanks Meter: 636
 
2,048 posts
Join Date:Joined: Jun 2012
Donate to Me
More
Try this:
1. Long-press home button and select the "cheese"
2. Go to the last tab called "Clear default Settings"
3. You will have there something called: TouchWiz Home. Clear it.
4. Go back to the start screen and long-press home button again.
27th June 2014, 07:46 AM   |  #3  
OP Junior Member
Thanks Meter: 1
 
29 posts
Join Date:Joined: Oct 2008
Quote:
Originally Posted by Joku1981

Try this:
1. Long-press home button and select the "cheese"
2. Go to the last tab called "Clear default Settings"
3. You will have there something called: TouchWiz Home. Clear it.
4. Go back to the start screen and long-press home button again.

Thanks for suggestion, but I already tried that. Home button still doesn't react to short press.

Actually, it does react to short press - when I want to wake up the phone. But it doesn't run launcher.
27th June 2014, 10:01 AM   |  #4  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Feb 2010
I have exactly the same problem. Button physically works fine will click to show lock screen when off , double press for s voice ( when on ) and hold for task manager. it just wont single press to actually go home..grrrrrrrr


Quote:
Originally Posted by Stasheck

Thanks for suggestion, but I already tried that. Home button still doesn't react to short press.

Actually, it does react to short press - when I want to wake up the phone. But it doesn't run launcher.



---------- Post added at 09:01 AM ---------- Previous post was at 08:41 AM ----------

ok solution for me was a full master reset via recovery. All good now.


Quote:
Originally Posted by tinentiuk

I have exactly the same problem. Button physically works fine will click to show lock screen when off , double press for s voice ( when on ) and hold for task manager. it just wont single press to actually go home..grrrrrrrr

27th June 2014, 10:41 AM   |  #5  
OP Junior Member
Thanks Meter: 1
 
29 posts
Join Date:Joined: Oct 2008
Yeah, I figure a reset/reflash will do, but it's another couple hours (which I don't have ) to restore everything after that
1st July 2014, 08:13 PM   |  #6  
Junior Member
Thanks Meter: 0
 
9 posts
Join Date:Joined: Nov 2011
I got the same problem
I was planning to upgrade firmware anyway though
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes