Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,730,865 Members 44,472 Now Online
XDA Developers Android and Mobile Development Forum

[KNOX] S4 mini and Knox

Tip us?
 
kev23m
Old
(Last edited by kev23m; 27th June 2014 at 06:36 PM.) Reason: Typo and update
#51  
Junior Member
Thanks Meter 2
Posts: 26
Join Date: Oct 2012
Quote:
Originally Posted by gladson1976 View Post
It takes some time to register the networks when you change the subscriptions. it usually takes 20 to 30 seconds for me.
Just go back to the main settings menu and then enter the Multi Sim menu after 30 secs. Should be fine.
Ok , gonna do a fresh install and give it another go. Will let it run thru the day and see.
I restored to the knox free samsung firmware and double checked , no knox files at all. So root and knox free is confirmed.

Update :
Same issue , as soon as data call selected , it searches for network again and changes setting in multi sim. Works perfectly with 1 card disabled.

Update :
Just tried it with another cm11 version released. What is happening is
1) if i disable mobile data for 2nd sim , mobile networks automatically switch off.
2) if i use wifi , once wifi disabled again mobile networks go off
Turning mobile networks on , data is enable for both sims and even though i select any sim in sim manager , it just keeps toggling on its own.
I take it the telephony patch is not working for my device in roms based on 4.4.3 and above. Works with 4.4.2
 
fburgos
Old
(Last edited by fburgos; 2nd July 2014 at 01:32 PM.)
#52  
Senior Member
Thanks Meter 131
Posts: 536
Join Date: Sep 2012
I have a story that I believe its knox related.

Couple of months ago I broke the screen of my first i9192 knox free phone, then I bought the second one wich came with knox bootloader.

I didnt mod my 2nd. phone because i didn't whant to trip knox and loose warranty, just rooted with saferoot it worked flawlesly all the time in 3g/2g auto, i never got any problems.

By the time cm11 came out i was so happy that i din't care about warranty and triped knox installing latest cwm recovery, flashed cm11 and it worked fine but I had a lot of signal drops while using 3G, but still I move on in 2g mode only I tried every build but still I have signal drops while using 3g mode some times where better than others, but still after some time the phone lost 3g signal, then I get bad quality on calls not connected to the network and no signal at all, but at the time I choose GSM only mode the signal got back and working fine but only in GSM mode, but none of the users of cm11 reported my issue then i thought was my modem tried different ones but with all i got bad quality on calls and network drops if i select 3G mode, even "wcdma auto" or "wcdma only" i end with no signal, no network, bad quality on calls that was fixed using "GMS only"

yesterday I was sugested to try back a stock firmware, the latest blackedition i proceed with the instalation, but my sorprise was that the issue persist, network drops in 3G mode bad quality of calls and not registered on network, then tried my phone with different simcards and all seems to work in 3g but didn't have the time to try them for long time, then its like mine that works for some time then drops, but my simcards were working flawles and connecting 3g signal on other phones then I didn't blame the sims, since they work on other phones.

still sad and pissed off I came home and disassembly the phone and exchange mainboards. the phone booted normaly in the old rom and working fine and connecting to 3G, then I update recovery and install a cm11 to test.

From yesterday untill now my phone has been working flawlesly on cm11 with the old knox free board, then I blame tripping Knox all the problems I had with 3G signal and somehow screwing the modem.

This video is with the Knox 0x1 board and the "bug"

http://youtu.be/s_v5jLVWb44

This video is with the Knox free bootloader board, wcdma works in both sims.


http://youtu.be/SODNFV4U-ao
Attached Thumbnails
Click image for larger version

Name:	20140627_223202.jpg
Views:	286
Size:	129.4 KB
ID:	2822083  
 
kev23m
Old
#53  
Junior Member
Thanks Meter 2
Posts: 26
Join Date: Oct 2012
My case is even stranger. I am now on knox free stock rom , all good no problems. The cm11 stable by sekil based on 4.4.2 works well too. It is only with the roms based on 4.4.3 and 4 that give me trouble with multi sim. If i use 1 card then works really well. The 3g signal is fantastic and it catches on also real fast.
I am left scratching my head how it works with 4.4.2 and not 4.4.3/4
Also like i had said before the knox counter is still 0 x 0 , updating shows processing failed.
 
kev23m
Old
(Last edited by kev23m; 2nd July 2014 at 02:57 PM.) Reason: typo
#54  
Junior Member
Thanks Meter 2
Posts: 26
Join Date: Oct 2012
Quote:
Originally Posted by fburgos View Post
I have a story that I believe its knox related.


yesterday I was sugested to try back a stock firmware, the latest blackedition i proceed with the instalation, but my sorprise was that the issue persist, network drops in 3G mode bad quality of calls and not registered on network, then tried my phone with different simcards and all seems to work in 3g but didn't have the time to try them for long time, then its like mine that works for some time then drops, but my simcards were working flawles and connecting 3g signal on other phones then I didn't blame the sims, since they work on other phones.

http://youtu.be/SODNFV4U-ao
I think it is a hardware defect. I flashed original firmware with knox and send it to samsung. They are replacing the mother board. I will get my handset back tomorrow. Hoping that my issue is resolved. Will root and check it tomorrow night itself. My knox flag never triggered.
The Following User Says Thank You to kev23m For This Useful Post: [ Click to Expand ]
Tags
knox
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes