Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,741,583 Members 40,362 Now Online
XDA Developers Android and Mobile Development Forum

HD audio on I9500 (or so it seems)

Tip us?
 
androidblue
Old
#1  
Junior Member - OP
Thanks Meter 1
Posts: 3
Join Date: Mar 2013
Default HD audio on I9500 (or so it seems)

Hi everyone

As an owner of the i9500 I was annoyed from the really low quality of call I was having. I tried the latest modems but had no luck in enabling the HD audio as was mentioned here

Here is how I managed to improve my voice call - I have no idea if it will work for others with I9500 - but please if it does for you, do tell

1) Download the I9500 XXUBMEA modem (I9500_XXUBMEA_MODEM.rar) from here or here (source). extract the I9500_XXUBMEA_MODEM.tar.md5 from it.

2) put your S4 in ODIN mode (power off, press the volume-down + home key + power button, a warning appears, let go of the keys, press volume up)

3) start ODIN. (I used ODIN 3.07 but I assume any will work), Press the "phone" button, select the I9500_XXUBMEA_MODEM.tar.md5 file. check the auto reboot option. press start.

4) this was my ODIN log:
Code:
Select Code
<ID:0/004> File analysis..
<ID:0/004> SetupConnection..
<ID:0/004> Initialzation..
<ID:0/004> Get PIT for mapping..
<ID:0/004> Firmware update start..
<ID:0/004> modem.bin
<ID:0/004> NAND Write Start!! 
<ID:0/004> Transmission Complete.. 
<ID:0/004> Now Writing.. Please wait about 2 minutes
<ID:0/004> Receive Response from boot-loader
<ID:0/004> RQT_CLOSE !!
<ID:0/004> RES OK !!
<ID:0/004> Removed!!
<ID:0/004> Remain Port ....  0 
<OSM> All threads completed. (succeed 1 / failed 0)

5) if successful, the phone will reboot. in my case it started but the mobile network was not working anymore. no problems.

5) time for service mode. Dial *#0011#
6) press menu key, than "back".
7) You're now in debug screen. press the menu key and "back". welcome to service mode
8) press the menu key and select 8 (Which is selecting the "WB-AMR status)
9) it should say

WB-AMR SETTING: 1(ON)
GSM WB: OFF(14)
UTMS WB: ON(10)

if that is the case, congratulations you just enabled the WB-AMR (well, you didn't but the firmware you installed did).

11) get the XXUFNC1 radio (i9500_RADIO_XXUFNC1.zip) from here. if you're using a computer, copy it to the the phone

12) power off the phone. reboot into recovery (volume-up + home key + power key, let go when you see the Samsung logo). I have CWM-based recovery V6.0.3.3

13) select "install zip" and select the i9500_RADIO_XXUFNC1.zip file.

14) reboot your phone (and fix root).

15) sound quality should be better now.


It improved my call sound quality - if it worked for you please share

PS
I tried the "latest" Chinese modem (i9500_RADIO_ I9500ZCUGND1) and the sound quality was horrible... don't use it
The Following User Says Thank You to androidblue For This Useful Post: [ Click to Expand ]
 
mrgv
Old
#2  
Member
Thanks Meter 2
Posts: 33
Join Date: May 2011
Hi,

This problem has been driving me crazy so I'm looking for a fix too. I have been burned in the past with bricking devices so I went ahead and tested out some steps (5-10.. notice your post doesn't include "10", although it's clear enough) and with my current setup (i9500, 4.4.2, I9500XXUFNA6) I cannot perform the service menu steps.. After dialing *#0011# I see something titled Service Menu but after menu->back nothing changes and after menu->key input or menu-> select .. 8 I get a "menu not exist" message..

Is this something that will not be a problem after installing the first radio in earlier steps? Or is this something else that is locked down in my phone?

Thanks.. just being extra careful not to brick yet another device this year... And thanks for addressing the horrible in-call sound quality of the S4.. I'm sick of not being able to understand anyone.. The work around I've found is to use voip such as skype which sounds just completely amazing and clear (so I know it's not a speaker problem)...
 
Gboss01
Old
#3  
Gboss01's Avatar
Senior Member
Thanks Meter 62
Posts: 238
Join Date: Mar 2013
Location: Durban
Quote:
Originally Posted by androidblue View Post
Hi everyone

As an owner of the i9500 I was annoyed from the really low quality of call I was having. I tried the latest modems but had no luck in enabling the HD audio as was mentioned here

Here is how I managed to improve my voice call - I have no idea if it will work for others with I9500 - but please if it does for you, do tell

1) Download the I9500 XXUBMEA modem (I9500_XXUBMEA_MODEM.rar) from here or here (source). extract the I9500_XXUBMEA_MODEM.tar.md5 from it.

2) put your S4 in ODIN mode (power off, press the volume-down + home key + power button, a warning appears, let go of the keys, press volume up)

3) start ODIN. (I used ODIN 3.07 but I assume any will work), Press the "phone" button, select the I9500_XXUBMEA_MODEM.tar.md5 file. check the auto reboot option. press start.

4) this was my ODIN log:
Code:
Select Code
<ID:0/004> File analysis..
<ID:0/004> SetupConnection..
<ID:0/004> Initialzation..
<ID:0/004> Get PIT for mapping..
<ID:0/004> Firmware update start..
<ID:0/004> modem.bin
<ID:0/004> NAND Write Start!! 
<ID:0/004> Transmission Complete.. 
<ID:0/004> Now Writing.. Please wait about 2 minutes
<ID:0/004> Receive Response from boot-loader
<ID:0/004> RQT_CLOSE !!
<ID:0/004> RES OK !!
<ID:0/004> Removed!!
<ID:0/004> Remain Port ....  0 
<OSM> All threads completed. (succeed 1 / failed 0)

5) if successful, the phone will reboot. in my case it started but the mobile network was not working anymore. no problems.

5) time for service mode. Dial *#0011#
6) press menu key, than "back".
7) You're now in debug screen. press the menu key and "back". welcome to service mode
8) press the menu key and select 8 (Which is selecting the "WB-AMR status)
9) it should say

WB-AMR SETTING: 1(ON)
GSM WB: OFF(14)
UTMS WB: ON(10)

if that is the case, congratulations you just enabled the WB-AMR (well, you didn't but the firmware you installed did).

11) get the XXUFNC1 radio (i9500_RADIO_XXUFNC1.zip) from here. if you're using a computer, copy it to the the phone

12) power off the phone. reboot into recovery (volume-up + home key + power key, let go when you see the Samsung logo). I have CWM-based recovery V6.0.3.3

13) select "install zip" and select the i9500_RADIO_XXUFNC1.zip file.

14) reboot your phone (and fix root).

15) sound quality should be better now.


It improved my call sound quality - if it worked for you please share

PS
I tried the "latest" Chinese modem (i9500_RADIO_ I9500ZCUGND1) and the sound quality was horrible... don't use it
Thanks for the tutorial. After flashing the modem via Odin I was able to access the service menu, which I couldn't do before.
My problem is that my settings show WB-AMR SETTING: 0(OFF). Is HD voice region locked? If I change my CSC will it then show as ON?
What is your CSC?

Current Device: Samsung GT-i9500 OctaCore
ROM: BareBones v6

"The two most important days in ones life are the day we born, and the day we find out why" - Mark Twain
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes