Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,731,426 Members 53,511 Now Online
XDA Developers Android and Mobile Development Forum

[Q] AT&T One X + Tethering with International SIM

Tip us?
 
gandalf_alpha
Old
(Last edited by gandalf_alpha; 5th May 2014 at 01:13 PM.) Reason: Spelling corrections
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: May 2012
Location: Denver
Default [Q] AT&T One X + Tethering with International SIM

Hey guys,

So I have a bit of a tricky question that I can't seem to find an answer for. My wife and I just move to Europe for work for 2 years. We had AT&T in the states, so my wife has an AT&T HTC One X+. We got our phones SIM unlocked before we left, and purchased French SIM cards that run on the Bouygues Telecom network. My phone (Lumia 925) can do wifi tethering no problem... My wife's on the other hand has issues. I keep getting the following error:
" There is a temporary network problem that prevents the enablement of the Mobile Hotspot function. Please retry later."
I have tried the following steps:
1. Rooting the phone.
2. Installing other hotspot apps (Both root and non-root)
3. Installed custom ROMs with hotfixes to remove AT&T data requirements.

I don't know if it's relevant, but when I do a reset on the phone, it doesn't automatically connect to Bouygues network for data. I have to manually add the APN every time. Once I do that, her mobile data works just fine, so I don't THINK that the APN is causing the problem...

Anyways, if anyone has an suggestions on how to fix this issue, I would be indebted to you... I've just never encountered this problem on any of my other Android devices and I have to believe that there is a simple solution to fix the problem that I've just not encountered. Thanks!!
 
deskicio
Old
#2  
Junior Member
Thanks Meter 2
Posts: 16
Join Date: Jun 2012
Location: Barcelona
I loved my international HOX, so when got dropped in water i said lets go for the ATT HOX+ that has LTE.

Big mistake! I have OP's same issue, im in spain and my provider is Movistar.

I bought it on e-Bay, configured all the APNs, I used settings from their webpage and also tried telephony.db values from an international rom, stock rom didn't tether.

Rooted stock (4.1.2 i think it was) still nothing.

Elegancia (4.2.2) ROM, still nothing.

Changed some stuff on the telephony.db, still nothing

Swapped the wifirouter.apk with the international wifirouter.apk, still nothing.

Nuked TetherGuard.apk, still nothing.

Installed Moto-X tether Xposed module, still nothing (probably cause it's for android 4.4).

I read that AOSP or Cyanogen ROMs don’t have this issue.

I also read that if you swap telephone.db from international version to USA version the phone goes into a reboot loop, cant find the post about it.

I guess the solution lays in something similar to the Moto-X tether patch, but i don't really have the time to fork the project, and try to get my tethering working.

Hope someone can give us a hand, im sure there are at least 5 more people in this same situation.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes