Post Reply

Charging and screen on

OP belloni

28th June 2014, 08:45 AM   |  #1  
OP Senior Member
Thanks Meter: 8
 
197 posts
Join Date:Joined: Jun 2013
Hi all, recently my phone when on charge the screen won't turn off, even when locked it turns itself on?! Any ideas to fix..
28th June 2014, 01:37 PM   |  #2  
BanziBaby's Avatar
Senior Member
Thanks Meter: 73
 
326 posts
Join Date:Joined: Oct 2010
If you have activated Developer Options then look in there to see if Stay Awake is ticked, if it is then untick it, if that is ticked then the screen will stay on when charging.
28th June 2014, 06:58 PM   |  #3  
OP Senior Member
Thanks Meter: 8
 
197 posts
Join Date:Joined: Jun 2013
Quote:
Originally Posted by BanziBaby

If you have activated Developer Options then look in there to see if Stay Awake is ticked, if it is then untick it, if that is ticked then the screen will stay on when charging.

That's not ticked, it seems quite temperamental. Can't work it out!
28th June 2014, 08:09 PM   |  #4  
BanziBaby's Avatar
Senior Member
Thanks Meter: 73
 
326 posts
Join Date:Joined: Oct 2010
Hmm, have you tried turning off Daydream in the display settings if you use it? Only other things I can think of are maybe a Xposed module if you use them or a app running in background.
1st July 2014, 04:53 PM   |  #5  
OP Senior Member
Thanks Meter: 8
 
197 posts
Join Date:Joined: Jun 2013
Quote:
Originally Posted by BanziBaby

Hmm, have you tried turning off Daydream in the display settings if you use it? Only other things I can think of are maybe a Xposed module if you use them or a app running in background.

Don't use daydream!

I've figured that it only does it from 90% to 100%?! Weird...
2nd July 2014, 10:19 AM   |  #6  
kazuni's Avatar
Senior Member
Flag Hong Kong
Thanks Meter: 214
 
663 posts
Join Date:Joined: Aug 2007
More
Quote:
Originally Posted by belloni

Don't use daydream!

I've figured that it only does it from 90% to 100%?! Weird...

I have exactly the same issue, changed different cable, charger, usb ports from pc, 95% of the time it will have the same problem.
3rd July 2014, 10:02 AM   |  #7  
OP Senior Member
Thanks Meter: 8
 
197 posts
Join Date:Joined: Jun 2013
Quote:
Originally Posted by kazuni

I have exactly the same issue, changed different cable, charger, usb ports from pc, 95% of the time it will have the same problem.

Well if there is no fix, then i'll have to take it back, as it keeps the phone very hot by keeping the screen on and off.
4th July 2014, 06:35 AM   |  #8  
kazuni's Avatar
Senior Member
Flag Hong Kong
Thanks Meter: 214
 
663 posts
Join Date:Joined: Aug 2007
More
Quote:
Originally Posted by belloni

Well if there is no fix, then i'll have to take it back, as it keeps the phone very hot by keeping the screen on and off.

There is a small fix... it is to use a USB cable that has no "data capability".

I've purchased a battery pack which has a short usb cable, which has no data connectivity function (only used for charging) and that will not trigger the monitor on in anyway. For the temporary time being, I have that used to charge every time.
4th July 2014, 11:20 AM   |  #9  
Junior Member
Thanks Meter: 0
 
10 posts
Join Date:Joined: Jul 2014
Quote:
Originally Posted by belloni

Don't use daydream!

I've figured that it only does it from 90% to 100%?! Weird...

Mine don't have this problem, maybe you can try contact sony care, they might can help with it.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Xperia Z2 Q&A, Help & Troubleshooting by ThreadRank