Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,769,021 Members 46,517 Now Online
XDA Developers Android and Mobile Development Forum

Z1 Compact with Polar H7 Sensor

Tip us?
 
claudio.86.
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: May 2014
Default Z1 Compact with Polar H7 Sensor

Hi Everyone!

I'd like to buy the Polar's H7 sensor to pair it with my z1 compact and to use it with the runtastic pro app. Though I'm not 100% sure if it's compatible.

In the official Polar's web page it says that it's compatible with the z1 (so I guess also with the Z1 Compact, but i'm suspicious about the fact that the Polar Beat app is not compatible with my device).

Did anyone already try it?

Cheers!
 
primalrunner
Old
#2  
Junior Member
Thanks Meter 0
Posts: 4
Join Date: Jan 2014
Location: Warsaw
Quote:
Originally Posted by claudio.86. View Post
Hi Everyone!

I'd like to buy the Polar's H7 sensor to pair it with my z1 compact and to use it with the runtastic pro app. Though I'm not 100% sure if it's compatible.

In the official Polar's web page it says that it's compatible with the z1 (so I guess also with the Z1 Compact, but i'm suspicious about the fact that the Polar Beat app is not compatible with my device).

Did anyone already try it?

Cheers!
Should work without any issues. My Z1c is still in transit but I am using Polar H6 with a 2 year old Samsung GS3 with 4.3 and it works great. I can confirm 100% towards the end of the week when Z1c arrives but I don't see any reasons why it wouldn't work. By the way, you can save a few by buying H6 instead on H7. The only difference is compatibility with legacy Polar equipment and some gym machines.
 
claudio.86.
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: May 2014
Default Thanks

Quote:
Originally Posted by primalrunner View Post
Should work without any issues. My Z1c is still in transit but I am using Polar H6 with a 2 year old Samsung GS3 with 4.3 and it works great. I can confirm 100% towards the end of the week when Z1c arrives but I don't see any reasons why it wouldn't work. By the way, you can save a few by buying H6 instead on H7. The only difference is compatibility with legacy Polar equipment and some gym machines.
Thanks for your answer.. I thought so too but I wasn't sure...btw the price difference now in the italian amazon is like 1 between H6 and H7 .
Keep me updated when your Z1c will arrive.
Cheers!
 
primalrunner
Old
#4  
Junior Member
Thanks Meter 0
Posts: 4
Join Date: Jan 2014
Location: Warsaw
Quote:
Originally Posted by claudio.86. View Post
Thanks for your answer.. I thought so too but I wasn't sure...btw the price difference now in the italian amazon is like 1 between H6 and H7 .
Keep me updated when your Z1c will arrive.
Cheers!
Z1c is here. Connected my Polar H6 with Endomondo and it works like a champ. By the way, Polar Beat wouldn't install for me either now (version incompatibility) though it installed just fine before on the SGS3.
 
dhchris
Old
#5  
dhchris's Avatar
Senior Member
Thanks Meter 23
Posts: 106
Join Date: Sep 2007
Location: Bergkirchen near Munich
Hello Claudio.
I've bought the H7 2 Month ago and at first i've got a few problems with connecting
the device. But actual I had no more problems with the firmware version .440 and .757 (KitKat).
The H7 works fine with Endomondo Pro and Runtastic Pro.
I hope I could help you.
Regards, Chris

Sent from my Xperia Tablet Z (SGP321) using XDA Premium HD app.
My active devices:
Sony Xperia Tablet Z SPG321 LTE - AOKP-KitKat-Nightly ROM
Sony Xperia Z1 Compact - Munjenis Custom Stock Rom - rooted
 
kanefan67
Old
#6  
Member
Thanks Meter 22
Posts: 66
Join Date: Oct 2010
Location: Hilversum
I'am using the Polar H7 sensor in combination with the Polar Beat app and Endomondo for several month now.
Since the update of Polar Beat to 1.1.1 the Z1C is officially supported.

I still have trouble pairing the sensor with the phone. Most of the time if have to switch off/on bluetooth and or turn off/on the app.
Most of the time the heart rate pops up all of a sudden, but every now and then pairing fails totally.

Are people experience similar issues?

My phone runs 4.4.2
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes