Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Failed to register sim every now and then

OP jadajada

22nd June 2014, 07:03 PM   |  #1  
OP Senior Member
Thanks Meter: 17
 
179 posts
Join Date:Joined: Jul 2007
My S4, i9505, pops up an error every now and then. It says "Unable to register simcard on network. Reboot now. When I reboot everything is fine, but it happens perhaps three or four times a day. There is no pattern to it, and I have ordered a new sim. After installing that the problem still happes.

The phone is out of warranty so I looking at options.

I see that the simcard/sd-reader is very simple to replace.

Do you agree with me that the simcardreader is probably to blame? What else could it be?
22nd June 2014, 08:46 PM   |  #2  
If you are on one of the latest KitKat firmwares, I've read some days ago that it's a software issue and it will be (probably) fixed when Samsung releases 4.4.3 for our S4
5th July 2014, 09:09 PM   |  #3  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Jan 2012
Quote:
Originally Posted by iJo09

If you are on one of the latest KitKat firmwares, I've read some days ago that it's a software issue and it will be (probably) fixed when Samsung releases 4.4.3 for our S4

Got a source for this? I'd love to know it was a software error with 4.4.2 - because then a rollback would fix it!

Thanks.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes