Watch This Now!

[Q] My Theme doesn't appear at Designs in the Settings

70 posts
Thanks Meter: 79
By Shialie, Member on 10th June 2014, 12:15 PM
Post Reply Subscribe to Thread Email Thread

Hey Androids,

I started my first Theme for Android. Because the new (CM11) Theme Engine gets more and more popular
I decided to make a Theme for this new Engine by using a Template.apk I found on github. Now I decided to publish my Theme on xda.
And my problem is that I can install my Theme, but
it does not appear on the Designs sections in my Settings and I'm 100% sure that my AndroidManifest.xml has no mistakes and I had no recompile errors.

On the official Cyanogenmod page about the new Theme Engine ( is written:

A theme APK is identified by meta-value data in AndroidManifest.xml. Here is an example:

By using meta-data we do not require special new tools.

[Changes to PackageManagerService]
During install time PackageManagerService will scan meta-data values in the manifest. If it finds
a meta-data name of "" then it will assume the APK is a theme and mark it as such.

And here is my AndroidManifest.xml:

What did I wrong? I had no recompile errors and I have absolutly no Idea how to solve this problem.
Maybe you can help me? I would be deeply grateful

- Paul

Last edited by Shialie; 10th June 2014 at 04:45 PM.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes