FORUMS

XeroAsh Theme for CM12

This theme by XDA Senior Member balrajs99 features a black and slate gray UI that gives your phone a … more

Samsung Galaxy S6 To Receive Major Camera Update

When the Samsung Galaxy S6 and S6 Edge were launched, they became the prime focus for … more

Tactile: An Addicting Game with Beautiful Material Design

The game industry has been around for decades, catering to a wide … more

Android’s Consistency and The User Experience

This is a site of power users, and it is fair to say that most of us are more … more
Post Reply Subscribe to Thread Email Thread

AT&T address book sync

26th June 2014, 09:31 PM |#11  
jm2k7's Avatar
Senior Member
Flag Black Mesa :P
Thanks Meter: 66
 
More
Quote:
Originally Posted by miller1821

The only problem with this is if you dont have an at&t account, you can't disable it this way because you won't be taken to a registration page. So how do you disable it if you use straight talk or any other service that uses at&t towers but isnt directly at&t? I would like to know this too and that's probably what the other person was asking. I don't see anything that can be disabled in system and i can't make it quit popping up.

Sent from my SAMSUNG-SM-G900A using XDA Free mobile app

for those who use the phone with another carrier, no option to disable it just does not appear, at first it's annoying, but after 3 or 4 attempts to divert pressing the back button not bother asking again sync with att.
 
 
4th July 2014, 05:40 PM |#12  
kettir's Avatar
Senior Member
Flag Central Ohio
Thanks Meter: 19
 
More
Open contacts
settings / contacts / at&t address book (it's at the bottom of the list)
you get the option there

Sent from my SAMSUNG-SM-G900A using xda premium
4th July 2014, 07:20 PM |#13  
OP Member
Thanks Meter: 13
 
More
I never posted a follow up to my original post so here's some information...

I could not get to the option to disable the address book sync because I had never activated the AT&T address book. While trying to activate it my phone would be stuck on the information screen telling me to call 611 to have it added to my account. After a day I finally realized that the initial activation has to be done over mobile data and will not work if done over WiFi. So I got it working and disabled the sync but eventually I just switched over to the international versions apps with no AT&T bloat from this thread http://forum.xda-developers.com/show....php?t=2796268.
Last edited by 556AR; 4th July 2014 at 07:23 PM.
6th July 2014, 12:53 AM |#14  
jm2k7's Avatar
Senior Member
Flag Black Mesa :P
Thanks Meter: 66
 
More
works well on Samsung Galaxy S5 AT&T SM-G900A

apk taken from odex g900f, apk list to replace:

system/app:
InCallUI.apk
InCallUI.odex

system/priv-app:
SecContacts.apk --> at&t --> SecContacts_Phone_FLAGSHIP_NA_ATT_WHITE.apk <-- delete and replace.
SecContacts.odex --> at&t --> SecContacts_Phone_FLAGSHIP_NA_ATT_WHITE.odex <-- delete and replace.
SecContactsProvider.apk
SecContactsProvider.odex
SecMms_Blue.apk
SecMms_Blue.odex
SecTeleService.apk
SecTeleService.odex

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes