Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,739,731 Members 50,766 Now Online
XDA Developers Android and Mobile Development Forum

[MOD]Write to extsd (root required)

Tip us?
 
evilbeef54
Old
(Last edited by evilbeef54; 15th June 2014 at 10:48 PM.)
#1  
evilbeef54's Avatar
Senior Member - OP
Thanks Meter 72
Posts: 301
Join Date: Jul 2008
Default [MOD]Write to extsd (root required)

OK so as you have noticed kit kat does NOT allow third party apps to write to the SD card, this is stupid, but lucky for us we have a fix IF you are rooted


we have 2 solutions

1) using root explorer or something similar go to

Quote:
/system/etc/permissions/platform.xml
and enter the permission that i have circled in red below (see attached) then it will work. Enter it so it looks EXACTALLY like it does below


2) the other option that MAY work is to go to the play store and download SDFix, that does the same thing (however myself and a few others are reporting that it isnt working as it is written)

big thanks to Mr Sam Epic for showing the fix, which came from Unknown Force in a SGS4 forum


****edit 4/19

had a few reports of SDFix not working, it didnt for me, i thought it was just a random error, what i did to fix it was to go into platform.xml and manually edit the permission so it looks exactally like the image below, i put in the extra return after the permission, there is not a logical reason why this fixed it, but it did

original thread here:

http://forum.xda-developers.com/show...php?p=51861458
Attached Thumbnails
Click image for larger version

Name:	correct.jpg
Views:	2939
Size:	190.7 KB
ID:	2800412  
Sprint Rooted Mogul Evo Evo3d GS3 GS4 GS5 (Sorry Sprint 13 years is enough)
VERIZON GS5

IF SOMEONE'S POST HELPS YOU PLEASE HIT THE THANKS BUTTON
The Following 14 Users Say Thank You to evilbeef54 For This Useful Post: [ Click to Expand ]
 
Syn Ack
Old
#2  
Syn Ack's Avatar
Senior Member
Thanks Meter 283
Posts: 1,166
Join Date: Jan 2011
Location: Atlanta
Seems like it worked, thanks.
Verizon HTC One M7 Unlocked Rooted
Verizon Galaxy S5 SafeStrapped Rooted
Verizon LG G3 or iPhone6 Coming Soon
 
davidstre
Old
#3  
davidstre's Avatar
Senior Member
Thanks Meter 134
Posts: 332
Join Date: Feb 2009
Location: NYNY
I gave this a try in Root Explorer. I have gone over it many times and I did everything correctly but now Titanium won't launch, Weatherbug won't load, and GAPPS fails everytime. I am using Odin to go back to stock now-- will try the other method.
VZW: Theres a map for that.
 
Nsane457
Old
#4  
Nsane457's Avatar
Junior Member
Thanks Meter 16
Posts: 20
Join Date: Mar 2008
Location: West Orange
After write to extsd is enabled, I would strongly suggest the Xposed Framework module Downloads2SD. It allows you to change default directories to the extsd. It seems to work for Chrome downloads as well.
The Following 2 Users Say Thank You to Nsane457 For This Useful Post: [ Click to Expand ]
 
tehgyb
Old
#5  
tehgyb's Avatar
Senior Member
Thanks Meter 171
Posts: 722
Join Date: Mar 2011
Location: Easton, PA
Here's a weird one... I edited the file exactly the way it should be, worked fine... played with a few things, edited build prop screwing around having fun. Boot looped because oops. No problem, Odin to stock. Fresh stock build.

Rooted, Edited the platform.xml again exactly the way required, reboot. Even system apps won't write to SD. Couldn't even install XDA app lol

Odin again, root, edit the xml exactly the depicted way again. Still nothing can write to SD. Wtf.

Anyone have a stock or working platform.xml I can peek at? Something is screwy here lol

I have all the source on my Linux box but I'm nowhere near it, unfortunately.
Galaxy S4g//Galaxy Nexus//Galaxy SII//Galaxy SIII//Galaxy SV

Retired Themer and Developer

If you like it, Hit thanks!
 
budies3
Old
#6  
Member
Thanks Meter 15
Posts: 79
Join Date: Sep 2009
Location: Seattle
Quote:
Originally Posted by Nsane457 View Post
After write to extsd is enabled, I would strongly suggest the Xposed Framework module Downloads2SD. It allows you to change default directories to the extsd. It seems to work for Chrome downloads as well.
I agree, I had issues with my S4 after moving to KK also with my new S5. And now with those of us on Verizon, we are lucky enough to have root Thanks to exposed you can start moving files around like before. Its just amazing how controlling companies feel they need to be.... Oh well, thanks for the Root Geohot, and Xposed rovo89 & Tungstwenty!
 
bodhisattvah
Old
#7  
bodhisattvah's Avatar
Junior Member
Thanks Meter 4
Posts: 16
Join Date: May 2014
Excellent! This worked on my N900V with 4.4.2 and root! (fix #1)

I thought my old file browser just wasn't reading root correctly, but with this, it's back to normal/pre OTA function. Thanks again!
 
psm321
Old
#8  
Junior Member
Thanks Meter 2
Posts: 20
Join Date: Nov 2009
Could you please add to the instructions, for option 1 at least, to double-check the permissions on the file? (They should be 644 and root/root). Was helping my brother and just went through lots of problems (everything crashing) and turns out the editor changed the permissions (found the answer on another site where someone described the same symptoms). I'm also wondering whether the permissions also have something to do with why it seems to sometimes not work for people...

The Following User Says Thank You to psm321 For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...