Post Reply

[Q] Rezound Root using liquidsmooth rom not detecting sd-card

OP ElReyJC

21st January 2014, 10:59 PM   |  #1  
OP Junior Member
Thanks Meter: 3
 
4 posts
Join Date:Joined: Jan 2014
Hey everyone,
I just recently rooted my phone (today) using the method (liquidsmooth 2.37) on the unlockr that uses moborobo and windroid htc rezound toolkit. I am having issues now that the phone doesn't recognize the sd-card. I can mount and unmount it on the settings>storage, I believe I no longer have internal storage anymore. Under Storage I see Internal Storage 2.34GB, then Sd-card 14.82GB, and at the bottom internal storage appears again but no space size is below it. I backed up my stock rom before doing the root, but it was saved to the internal sd-card. And CWM doesn't mount the sd-card so I can even restore to the original. I have seen post about flashing the stock recovery using the all-in-one toolkit. I am not sure have exactly to do this or if that would help. Also for some reason I can no longer connect (debugging, not engaging even thought phone says it is on) to the toolkit ever since I completed the root. I have tried connecting through wifi with thoughts of using the adb commands, but I am not comfortable at all using that method.

Could anyone help fix this. If I can fix the sd mounting issue I would keep the liquidsmooth rom. Also if someone can help me understand how to go back to a stock rom I would gladly do it as well. I have seen several post about flashing RUU's but I am don't entirely understand that process as well.

Sorry if I come across as a complete idiot, I am just not that great with this stuff.
22nd January 2014, 05:34 PM   |  #2  
OP Junior Member
Thanks Meter: 3
 
4 posts
Join Date:Joined: Jan 2014
Question switch storage for sd card
Hey everyone I have been looking into more into my phone. Just elaborate from my first post I went from ICS to JB on the rezound. From several post I have seen is that the storage gets a little weird.

On my phone I can mount the sd card under settings>storage, but the phone doesn't recognize it as the sdcard, but rather as the external_sd (in root explorer). When I try to open sdcard in root explorer it tells me not mounted or can't mount. I believe my phone and all its apps for downloading or storage want to use the sdcard link, but my sd card is appearring as external_sd. How can I tell my phone to recognize my sd card as sdcard (in root explorer) or tell my phone to store in external_sd (where my sd card is appearing right now)?

Thanks for any help.
23rd January 2014, 01:35 PM   |  #3  
OP Junior Member
Thanks Meter: 3
 
4 posts
Join Date:Joined: Jan 2014
Hey everyone,

I fixed my issue. After reading several post the issue of losing internal storage is common when changing android versions. I read to flash firmware patch. I did this and I also Read that USB debugging is an issue when super user isn't correct. I downloaded supersu from play, even though liquidsmooth has it built in. I connected to my PC and was connecting. Then after my phone detected internal SD card and said needed to be formatted. I formatted it within the phone boom.! Done!

Sent from my ADR6425LVW using xda app-developers app
The Following 2 Users Say Thank You to ElReyJC For This Useful Post: [ View ]
23rd January 2014, 02:31 PM   |  #4  
acejavelin's Avatar
Senior Member
Flag Bismarck, ND
Thanks Meter: 520
 
1,711 posts
Join Date:Joined: Sep 2009
Donate to Me
More
This is very odd... I have to question whether the initial flash worked properly if su wasn't working, LiquidSmooth is very stable and bug-free ROM. What HBoot, recovery, and radio versions do you have? What "patch" did you flash?
2nd February 2014, 08:47 PM   |  #5  
Junior Member
Thanks Meter: 0
 
12 posts
Join Date:Joined: Feb 2014
Thumbs up
Quote:
Originally Posted by ElReyJC

Hey everyone,

I fixed my issue. After reading several post the issue of losing internal storage is common when changing android versions. I read to flash firmware patch. I did this and I also Read that USB debugging is an issue when super user isn't correct. I downloaded supersu from play, even though liquidsmooth has it built in. I connected to my PC and was connecting. Then after my phone detected internal SD card and said needed to be formatted. I formatted it within the phone boom.! Done!

Sent from my ADR6425LVW using xda app-developers app

Thank you so much I too flashed the 2.37 Liquid Smooth rom and had the above issue, with nothing being mounted under sdcard, at least in root explorer. When attempting to install some of my larger apps from the play store they would tell me that "APPNAMEHERE" requires external storage for some functionality. Please retry after ensuring that external storage space is available. Again when attempting to enter the sdcard folder under root explorer it would notify me that "the sd card is not currently mounted". Under the mnt folder there was no sdcard just external_sd. While under STORAGE there was sdcard0 and sdcard1. With sdcard0 being completely empty, and sdcard1 just having the files I had put on the removable sd card.

I didn't do anything about firmware, but I did follow your suggestion about reinstalling supersu from the play store then connecting to the computer. Immediately after doing so the phone recognized the sdcard and offered to format it for me, and I can now sdcard is mounted properly again and the folder can be accessed under root explorer. One of the other symptoms of the above is that if I went to phone setting then storage I could see all of my storage both internal and on the external sd card but there was nothing below the external sd card space, where now it has total space for both types below the sd card storage. Again thanks so much I had been banging my head against this wall for days as this is the first time I flashed a rom to my rezound or any android for that matter.
6th February 2014, 05:21 PM   |  #6  
OP Junior Member
Thanks Meter: 3
 
4 posts
Join Date:Joined: Jan 2014
I'm glad my experienced helped someone else, cause like you I had no idea what to do

Sent from my ADR6425LVW using xda app-developers app
The Following User Says Thank You to ElReyJC For This Useful Post: [ View ]
7th July 2014, 11:57 PM   |  #7  
Frazercrib's Avatar
Member
Flag Lagos
Thanks Meter: 8
 
39 posts
Join Date:Joined: Jul 2013
Mine is a little bit complicated..I'm running the latest liquid smooth rom, my internal storage is detected by file managers(root explorer,xplore file manager). But in the settings/apps/ the internal storage is not present. And liquid smooth seems to be the only rom with this bug.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes