Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,807,938 Members 49,266 Now Online
XDA Developers Android and Mobile Development Forum

Samsung Galaxy S 5 text messaging solution!

Tip us?
 
fanatik229
Old
#1  
Junior Member - OP
Thanks Meter 2
Posts: 3
Join Date: Apr 2014
Default Samsung Galaxy S 5 text messaging solution!

I don't know who else has been having this issue, but there are times where I would not be able to send or receive text messages until I restarted my phone. I finally narrowed it down to the main culprit, which is "Smart Network Switch" under the "Wifi" settings. The problem occurs if you are actively connected to wifi and you turn the screen off. Your GS5 is in sleep mode now but still has wifi connected. When the "Smart Network Switch" is off there is no problem, but when it is on it prevents text messages, phone calls and MMS. It happens either the phone is charging or not charging.

What I found to be the fix is to disable the "Smart Network Switch" option, then turn off wifi and go on the internet and load any web page. This usually would kick start the text messages to be sent to my phone. Once you disable the smart switch, you can keep wifi on all the time and you will not have any problems with texts, MMS or calls.

tl;dr

DISABLE SMART NETWORK SWITCH = WORKING TEXT MESSAGES!!!!

Please let me know if this fix works, thanks.
The Following 2 Users Say Thank You to fanatik229 For This Useful Post: [ Click to Expand ]
 
mahanddeem
Old
#2  
mahanddeem's Avatar
Senior Member
Thanks Meter 124
Posts: 1,207
Join Date: Nov 2011
Useless feature IMO, I kept it off since first time I set up my device.
 
omgbossis21
Old
#3  
omgbossis21's Avatar
Senior Member
Thanks Meter 126
Posts: 369
Join Date: Jul 2013
Always had mine off, always had text issues.
 
soyimparable
Old
#4  
soyimparable's Avatar
Member
Thanks Meter 5
Posts: 32
Join Date: Apr 2014
I'll try this !

Enviado desde mi SM-G900T
Sent from my Samsung Galaxy S5 SM-G900T using XDA developers premium
 
vvveith
Old
#5  
vvveith's Avatar
Senior Member
Thanks Meter 87
Posts: 423
Join Date: Jul 2010
Location: Cleveland

 
DONATE TO ME
Thumbs down Had mine off from day one.

Quote:
Originally Posted by fanatik229 View Post
I don't know who else has been having this issue, but there are times where I would not be able to send or receive text messages until I restarted my phone. I finally narrowed it down to the main culprit, which is "Smart Network Switch" under the "Wifi" settings. The problem occurs if you are actively connected to wifi and you turn the screen off. Your GS5 is in sleep mode now but still has wifi connected. When the "Smart Network Switch" is off there is no problem, but when it is on it prevents text messages, phone calls and MMS. It happens either the phone is charging or not charging.

What I found to be the fix is to disable the "Smart Network Switch" option, then turn off wifi and go on the internet and load any web page. This usually would kick start the text messages to be sent to my phone. Once you disable the smart switch, you can keep wifi on all the time and you will not have any problems with texts, MMS or calls.

tl;dr

DISABLE SMART NETWORK SWITCH = WORKING TEXT MESSAGES!!!!

Please let me know if this fix works, thanks.
WiFi calling is the culprit with text messages not reaching the phone. sends okay but until I turn WiFi calling off, I get no text messages with the latest nf6 upgrade.

Asus Transformer Prime/LG G3/Samsung Note 3
Stock Radio latest version
Latest Samsung Update
SanDisc SD 32G Class10
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes