Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,729,619 Members 46,737 Now Online
XDA Developers Android and Mobile Development Forum

[MOD] Enable Stock Hotspot on Verizon

Tip us?
 
bucwylde23
Old
#31  
Senior Member
Thanks Meter 22
Posts: 124
Join Date: May 2010
Quote:
Originally Posted by RockyCJC View Post
This MOD worked flawlessly using terminal emulator. You get an error after running the adb and sh commands but it still worked nonetheless. Your phone will lock up after the last command and reboot itself...but then its money!!

Sent from my SM-G900V using Tapatalk
What kind of speeds are you getting on connected devices?
 
kbdrox
Old
(Last edited by kbdrox; 23rd June 2014 at 06:53 PM.)
#32  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Aug 2010
Quote:
Originally Posted by tangoboyz View Post
SO I followed these instructions and this is what i get both from adb and Term Em.

mount: No such file or directory
: Read-Only file systemramework-res.apk.bak
: Read-Only file systemramework-res.apk
/mnt/sdcard/download/toggle/run.sh[8]: /mnt/sdcard/download/toggle/sqlite3: can't execute: permission denied


I use the same folder structure you did, created a download folder and extracted the zip...

Thoughts?
Had the exact same problem. Here is how I fixed it:

Changed run.sh to only:

#!/sbin/sh
cp /system/framework/framework-res.apk /system/framework/framework-res.apk.bak
cp /mnt/sdcard/Download/system/framework/framework-res.apk /system/framework/framework-res.apk

This removes all the references to installing the toggle and just the framework replacement


In terminal emulator

su

mount -o remount,rw /dev/block/mmcblk0p23 /system
sh /mnt/sdcard/Download/toggle/run.sh


Phone locks up. Hold down power button till it reboots

Then I added the toggle with SQlite Editor.

Bingo

Yeah Xposed Xtether works, but it breaks S Health.

Yeah you can fix S Health but you lose Private Mode.

I'm anal. I don't want any part of my phone not to work. I'll take the extra steps!
 
lbrito
Old
#33  
Junior Member
Thanks Meter 4
Posts: 10
Join Date: Jun 2010
Quote:
Originally Posted by kuronosan View Post
Lesson learned. Don't replace framework manually.

Sent from my GT-P5110 using Tapatalk 2
I think I learned this lesson as well. Rather than edit the Run.sh script, I executed the commands via ADB and copied the framework file. I got the reboot, but was never able to get past the Verizon logo. Tried clearing Dalvik Cache, even factory reset, nothing worked. Ended up having to use ODIN to flash clean firmware. On the positive side, in the last week to two weeks, my battery life had gone from absolutely amazing to almost not making it through the day. After a fresh install, I'm getting my 2-3 days of battery life.

Ended up taking the easy route and using the Xposed XTether module. Works like a charm.

Wonder why this didn't work out.
 
RockyCJC
Old
#34  
Member
Thanks Meter 20
Posts: 49
Join Date: Jun 2011
Location: Richmond, VA
Quote:
Originally Posted by bucwylde23 View Post
What kind of speeds are you getting on connected devices?
Sorry I hadn't replied sooner. I have poor speeds on 4g at my house and in my office so I haven't had a chance to do a decent test. I usually use hotspot if I am traveling which I have been doing fairly often to visit my dad at the hospital on NJ. Anyway, at the hospital I get XLTE speeds of 50 down and 30 up. I just ran a test from my iPad mini and got 40 down and 20 up. There is a difference but I could run the speed test 10 times from my phone and I guarantee that at least 1/3 of the time I will see that kind of fluctuation. Plus I would expect some loss of speed when tethering to begin with.

So for me, this MOD is awesome. Though I'll probably be giving safestrap and beans stock ROM soon which has tethering fixed natively.

Sent from my SM-G900V using Tapatalk
 
xkwr27
Old
#35  
Member
Thanks Meter 17
Posts: 45
Join Date: Nov 2012
Location: Longview
Maybe its everything else I did to my s5 but I got no sh errors or lockup prior to auto reboot using terminal emulator, and it booted a little faster than normal and tether worked right off. Now to find that db line to add tether to the bar at the top.
thanks dude

Sent from my SM-G900V
 
bpoole23
Old
#36  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Dec 2010
Default i cant get it

Hi yall. First thanks for sharing the MOD, and I look forward to get it working.
Im not sure how to write a file and save it in order to replace the original. Instead I opened up the original via Root Explorer and simply copy/paste the OP code. Tried in terminal emulator as well as ADB. Id prefer to use ADB, so this is what Im focusing on.
The error says sh is not recognized as an intera; or external command, operablle program or batch file.
Ive flashed ROMs, used ADB a few times, ODIN a bunch, but i can only follow directions. I dont know anything about writing or deciphering code if somethings not working.
Im rooted. Ive extracted the .zip in the DL folder in the internal SD card. Replaced the run.sh file.
Can anyone help?
Im not scared to read or research, but most of the stuff I can find assumes I understand what the hell is going on in the first place...
Cheers yall
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes