How to Fix the Nexus Available Storage Bug – XDA TV

Is your Nexus device only showing half of the available storage as it should? Many … more

Don’t Forget About Birthdays with Birthday Reminder

A person’s birthday is, without a doubt,one of the most important days in his … more

Don’t Fear Flashing with I Don’t Want You!

The XDA message boards are full of various modifications, with many of these helping … more

Quo Vadis, Open {Source, Standards, World}? w/ Jan Wildeboer – XDA:DevCon 2014

Open Source was a big topic at this years XDA:DevCon … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Samsung Galaxy S3Missing drivers???

OP alextac98

29th June 2014, 07:00 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Jun 2014
I recently got in the buisness of messing with my android phone's rom. Long stories short, during my attempt at flashing Cyanogen mod(which didn't work) some of my drivers got uninstalled. I can tell because of a few symptoms.

First, my phone will not see my sim card. It isn't the sim card(Ive checked) and I've narrowed it down to my efs folder is blank. I think this is because of a missing driver. I have no imei number or anything like that

Also, media just doesn't play. I can not hear anything as well as the media just flat out doesn't play. Youtube and any other app/browser just cannot get it to play anything.

These are the noticable things. I think its because of the drivers. Ive tried flashing new roms including stock. Problem is that im limited to 4.3 roms and above because I have samsung's new 4.4 locked bootloader. Any ideas?

PS I have the Samsung Galaxy s3 from AT&T. model number is SGH-I747

PSS This is my second post so sorry if it is in the wrong catagory or if anything is wrong. Im a newbie to this forum
29th June 2014, 06:03 PM   |  #2  
Member
Thanks Meter: 40
 
92 posts
Join Date:Joined: Dec 2013
Have you tried this?
http://forum.xda-developers.com/show...php?p=29514032
Sent from my SAMSUNG-SGH-I747 using XDA Free mobile app
29th June 2014, 11:24 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Jun 2014
No backup
Quote:
Originally Posted by Viper67857

Have you tried this?
http://forum.xda-developers.com/show...php?p=29514032
Sent from my SAMSUNG-SGH-I747 using XDA Free mobile app

No I have not created any sort of backup of the necesary files. Yes, I know that I should have, but I had no idea about these folders before I started to play with my rom. Definitely a lesson learned.
29th June 2014, 11:37 PM   |  #4  
Member
Thanks Meter: 40
 
92 posts
Join Date:Joined: Dec 2013
If you read further into it, it tells you how to get your imei back even without a backup

Sent from my SAMSUNG-SGH-I747 using XDA Free mobile app
2nd July 2014, 09:18 AM   |  #5  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Jun 2014
Quote:
Originally Posted by Viper67857

If you read further into it, it tells you how to get your imei back even without a backup

Sent from my SAMSUNG-SGH-I747 using XDA Free mobile app

I tried to download the documents, but it wouldn't work. It gave me an overtraffic error from Dropbox. Although this might fix one issue, I do not think that I have a lost imei, since other things are not working as well. I still believe that my phone is missing drivers.
2nd July 2014, 06:12 PM   |  #6  
DocHoliday77's Avatar
Recognized Contributor
Flag HuntsVegas!!!
Thanks Meter: 6,502
 
9,195 posts
Join Date:Joined: May 2011
Donate to Me
More
I don't believe it is a driver issue. The first thing you need to do is install terminal emulator from the play store and enter the following:

getprop ro.bootloader

If, and ONLY IF it says you are on NE4, try flashing the NE4 modem. You can get it from my post here: http://forum.xda-developers.com/show...php?p=53627484

If you are on any other firmware build, find and flash the modem thst matches that build. (If the getprop command says you have MJB firmware, flash the MJB modem)

If you still have problems, flash the same firmware as you currently have via odin and factory reset. Backup first though!! This will wipe all your data including the internal sd.
(DO NOT FLASH OLDER FIRMWARE!!!! Only the same or newer as what you currently have!)

Explanation: if you have an incompatible modem installed, it will usually show unknown for your baseband and imei. This can also cause the EFS folder to appear blank. The reason your media won't play is because drm content relies on the contents of the EFS, so if its blank/cant be read, most media will not play.
Also if the wrong modem is installed, it will not be able to read your SIM card.

If after flashing the modem, and the full firmware you still have these problems, and your IMEI is not properly showing, PM me and I can help you further.
10th July 2014, 01:49 AM   |  #7  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Jun 2014
Smile
I followed what the other post said. I installed the modem and everything worked. However, then my wifi didn't work. I then installed this http://www.androidfilehost.com/?w=fi...6a640e15f746e7 using TWRP (CWM works as well, tho haven't tried it). After that, I wiped all cache (Dalvik and normal) and did a factory reset. It worked like a charm. I am so happy, now I can go back to the phone I love!!! Any more questions, just post it or pm me. Thanks for all who help

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes