Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

T-mobile Messaging problem sending receiving MMS - SMS

OP drago10029

22nd March 2014, 09:34 AM   |  #1  
drago10029's Avatar
OP Senior Member
Phazon Mines
Thanks Meter: 79
 
467 posts
Join Date:Joined: Nov 2008
More
Like the title says.

BASIC INFO
Here's some basic info. I live in NYC, have t-mobile, have experienced the issue with with my Moto X (T-mobile - aka GSM unlocked) and in the past T-mobile HTC One. both running 4.4 and 4.4.2. Using the stock apps, no third party stuff.

THE ISSUE
My MMS have been hit or missed. They all show as sent on my Moto X but don't always get received (I confirm with the people I'm sending to & check "view details")
This has been going on for like 2 months. 2 days ago, I've been getting SMS really late. for example, receiving SMS 2 days later (I check the timestamps)

TROUBLESHOOTING
So far i've done EVERYTHING lol:
  1. factory reset
  2. 3 moto x warranty exchanges
  3. Tried using a T-mobile HTC One
  4. reset app caches
  5. tried not installing any (just factory apps and settings as a controlled variable)
  6. tried different locations (with without WiFi)
  7. sent MMS with images below 1mb limit and even smaller just to be safe
  8. Using new SIM cards with EACH phone

I have concluded that T-mobile has network issues they refuse to acknowledge and I plan on leaving them for a better carrier, cheaper isn't better in T-mobile's case.

Any wanna offer some wisdom, Could someone help a brother out? Thanks in advance!
Last edited by drago10029; 6th April 2014 at 11:28 PM.
6th April 2014, 11:29 PM   |  #2  
drago10029's Avatar
OP Senior Member
Phazon Mines
Thanks Meter: 79
 
467 posts
Join Date:Joined: Nov 2008
More
Motorola (along with my own testing) has confirmed that the stock messaging app has bugs for sending receiving MMS/SMS
10th July 2014, 02:02 PM   |  #3  
drift08's Avatar
Senior Member
Thanks Meter: 5
 
129 posts
Join Date:Joined: Oct 2008
More
I am having a smiliar issue with sms and mms. I am working on a S4 clone (w/ 3G only). It use to be able to send sms to other phones. Recently, it can only send to T-Mobile carriers only. I can receive sms, mms from any other carriers. Sometimes, I can rarely send sms and mms to other carriers. Maybe once in every 20 times. Most of the time, it says "Sending..." and then auto notification saying "not send". Sometimes, the auto notification are instant (pops up right after I hit send button). I am using the stock msg app. any idea? I triple checked my APN and it goes online fine.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes