Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,730,673 Members 40,907 Now Online
XDA Developers Android and Mobile Development Forum

[Q] bricked my Lenovo A766 (MTK6589m)

Tip us?
 
MomenMamdouh
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Jan 2014
Question [Q] bricked my Lenovo A766 (MTK6589m)

Hey guys

my lenovo a766 lost its IMEIs after flashing a custom ROM, and i have restored them successfully using SN_WRITE_TOOL


The problem now i always have no service signal, also WIFI warning: Err = 0x10 .

I have tried:

1- restoring stock ROM using SP flashtool, still no service.
2- different versions of modem.img, modem db, and apdb using SN_WRITE_TOOL but still can't get ride of no service signal.
3- the solution for WIFI warning: Err = 0x10 described here but no success.

I don't have a Backup nvram.bin or nvram_user_data (nvram.tar)

so, could you guys share with me nvram.bin, and nvram.tar files of a working lenovo a766 ?

thanx;
 
MomenMamdouh
Old
#2  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Jan 2014
please help me any way you feel help me bring back my phone or any software, i will appreciate.
 
Nick Hill
Old
#3  
Junior Member
Thanks Meter 7
Posts: 17
Join Date: Dec 2013
Quote:
Originally Posted by MomenMamdouh View Post
please help me any way you feel help me bring back my phone or any software, i will appreciate.
Hi

I unbricked my phone with this firmware
http://www.nickhill.co.uk/orig_A766_S117_130913.zip
(it will be uploaded in about an hour. MD5 eb5728231668ea583d0b9c41be9efeb2 )

The scatter file and target binaries are in target_bin

Drivers and the flashtool I used are in A766 inst and sw

Use at your own risk, of course!

I found when I re-loaded this firmware, the priginal IMEIs came back.

Feel free to leave thanks!!
The Following User Says Thank You to Nick Hill For This Useful Post: [ Click to Expand ]
 
MomenMamdouh
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Jan 2014
Quote:
Originally Posted by Nick Hill View Post
Hi

I unbricked my phone with this firmware

Thanks for the original firmware, my IMEIs already restored, but still have the no service signal, i think my nvram is corrupted.
Plz could you use MTKDroid tool to backup your working nvram.bin and nvram userdata, then i can restore my IMEIs using SN_WRITE_TOOL and get ride of no service signal.
 
MomenMamdouh
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Jan 2014
Plz i need a working lenovo a766 nvram.bin file.
Thanx;
 
faisal_786_uk
Old
#6  
Junior Member
Thanks Meter 2
Posts: 1
Join Date: Jan 2014
Quote:
Originally Posted by MomenMamdouh View Post
Plz i need a working lenovo a766 nvram.bin file.
Thanx;
If you still need the files, let me know and i'll upload it.
The Following 2 Users Say Thank You to faisal_786_uk For This Useful Post: [ Click to Expand ]
 
MomenMamdouh
Old
#7  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Jan 2014
Quote:
Originally Posted by faisal_786_uk View Post
If you still need the files, let me know and i'll upload it.
thank you;

I unbricked my phone using the maui meta 3g tool 👍
thanks again.
 
useruz
Old
#8  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Dec 2011
Quote:
Originally Posted by faisal_786_uk View Post
If you still need the files, let me know and i'll upload it.
Please upload nvram.img of Lenovo A766 for me, brother
 
zagzagon
Old
#9  
zagzagon's Avatar
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Dec 2012
Default bad phone

Hello good people I have a problem
I try to solve the problem more than a month .My phone is lenovo a766
month ago The device started to lose reception slowly until completely lost
trying to change baseband but no luck ...soI decided to change "rom" after replacing the rom, the device stuck on bootloader So I tried to replace him through "sp flashtool" but without success because the computer does not recognize the lenovo a766 I tried a number of ways like: Installing "USB VCOM driver" ;Installing lenovo drivers; Installing mtk mt6589 driver ;I took out the battery I plugged the usb while I click volume up and nothing happens. Except once the computer is able to recognize the device. I also tried through metamode Can not in any way .In addition all the zip files that I puts in sd can not flashing with recovery mode
I beg you please help me I am frustrated ... I do not care from the mobile I have to solve it.
I have all the necessary files.

In addition: I'm using windows 8 And I install the driver like I should

Sent from my ARCHOS 80G9 using XDA Free mobile app

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Hide Numbers on Your SMS and Call Logs with Reflection

How many times have you given your device to someone else in order to show them a … more

Implement Split View in Your LG G2 KitKat Rom with Automated Installer

Some of you may have remembered a story on the Portal a few weeks back … more

Cast Your Device Screen the Way it Was Meant to be with Second Screen

Not too long ago here on the XDA Portal, we covered how Google had made … more

Samsung Gear Live Unboxed the XDA Way – XDA Developer TV

XDA Developer TV Producer AdamOutleris known for his XDA Unboxingseries where … more