Android 5.1 Possibly Coming February 2015

Google released Android 5.0 just over a month ago, and since then Lollipop has been trying to … more

Double Tap to Wake on the Nexus 6 Without Root

A few weeks ago, we featured an app which allowed the Nexus 6 to regain the double tap to wake … more

Make Your Own Heat Sink for the LG Optimus 4X HD

Its not a rare occurrence that performing a resource heavy task on your Android device (e.g. … more

Learn How to Create an Old School Dialer

XDA is not only a great source for custom ROMs, kernels, and various modifications for numerous … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Root for the One Plus One?

OP adambombz

14th July 2014, 12:09 AM   |  #21  
The Jack of Clubs's Avatar
Senior Member
Flag Houston
Thanks Meter: 476
 
2,729 posts
Join Date:Joined: Jan 2007
More
Quote:
Originally Posted by armanid27

I amd trying to unlock bootlaoder, and install TWRP on my ONE+. I have tried both android SDK, and TOOLKIT FOR ONEPLUS FROM XDA, and I cannot get fastboot devices to recognize my One+.

What I have do so far:

My PC: windows 7 - 64bit

Installed SDK kit form developer.android.com, and installed the latest composite usb driver from Google.

Installed OnePLus toolkit and tried using that, no dice.

when I execute "fastboot devices" from my fastboot folder, my prompt hangs "waiting for device" FOREVER!!!

"ADB DEVICES" WORKS PERFECTLY, AND ECHOES MY SERIAL NUMBER BACK TO ME."

if you can do "adb devices" and get a response, then it doesnt sound like you are in fastboot mode. try doing "adb reboot bootloader" and see if your phone goes into fastboot. then in fastboot mode, see if you can see your phone in device manager.
14th July 2014, 01:01 AM   |  #22  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Jul 2014
root OPO
Quote:
Originally Posted by The Jack of Clubs

if you can do "adb devices" and get a response, then it doesnt sound like you are in fastboot mode. try doing "adb reboot bootloader" and see if your phone goes into fastboot. then in fastboot mode, see if you can see your phone in device manager.

Here are the steps I take (in order that I do them)

Step 1 . adb reboot bootloader <<- This reboots my OPO into Fastboot Mode, an I can actually see in that mode.

Step 2. fastboot oem device-info <<- this hangs forever, or any other fastboot command, the OPO hangs with "<waiting for device>" as if it is no longer attached.


So, yes, I am in fastboot mode, and my OPO actually displays the CM face logo and underneath it says "fastboot mode" on its display.
14th July 2014, 01:25 AM   |  #23  
The Jack of Clubs's Avatar
Senior Member
Flag Houston
Thanks Meter: 476
 
2,729 posts
Join Date:Joined: Jan 2007
More
Quote:
Originally Posted by armanid27

Here are the steps I take (in order that I do them)

Step 1 . adb reboot bootloader <<- This reboots my OPO into Fastboot Mode, an I can actually see in that mode.

Step 2. fastboot oem device-info <<- this hangs forever, or any other fastboot command, the OPO hangs with "<waiting for device>" as if it is no longer attached.


So, yes, I am in fastboot mode, and my OPO actually displays the CM face logo and underneath it says "fastboot mode" on its display.

just run fastboot oem unlock (saying you actually want to unlock, its not needed for root).
Post Reply Subscribe to Thread

Tags
customizing, cyanogenmod 11s, one plus one, root
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes