Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Nexus 7 Deb, 4.4.2, KVT49L, VPN causes LTE to reset

OP raidscsi

5th March 2014, 10:25 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
8 posts
Join Date:Joined: Oct 2010
I have unlocked and rooted device, but running stock os. Installing a privateinternetaccess app or using a OpenVPN app to make a VPN connection causes the LTE connection to turn red, and reset. Resetting all the data connections on the device. I can make a connection to my personal OpenVPN server running at home, using the same OpenVPN app with a different profile, and it works fine. I think the difference is my personal VPN uses IPv4 and the private internet access is IPv6.

I am also wondering if this is related to the TUN/APN settings that were changed from 4.3 to 4.4.

Does anyone have a working PIA VPN on a Stock Kitkat Verizon device?


Here is the log from the OpenVPN client when trying to connect to the us-east.privateinternetacess.com gateway.

Code:
2014-03-05 10:58:05 Running on Nexus 7 (deb) google, Android API 19, version 0.6.10, official build
2014-03-05 10:58:05 Log cleared.
2014-03-05 10:58:13 TCP/UDP: Incoming packet rejected from [AF_INET]66.55.150.187:1194[2], expected peer address: [AF_INET]208.53.180.50:1194 (allow this incoming source address/port by removing --remote or adding --float)
2014-03-05 10:58:13 or from peer address: [AF_INET]50.7.31.18:1194
2014-03-05 10:58:13 or from peer address: [AF_INET]50.7.1.50:1194
2014-03-05 10:58:13 or from peer address: [AF_INET]208.53.180.74:1194
2014-03-05 10:58:23 TCP/UDP: Incoming packet rejected from [AF_INET]66.55.150.187:1194[2], expected peer address: [AF_INET]208.53.180.50:1194 (allow this incoming source address/port by removing --remote or adding --float)
2014-03-05 10:58:23 or from peer address: [AF_INET]50.7.31.18:1194
2014-03-05 10:58:23 or from peer address: [AF_INET]50.7.1.50:1194
2014-03-05 10:58:23 or from peer address: [AF_INET]208.53.180.74:1194
2014-03-05 10:59:10 PID_ERR replay-window backtrack occurred [1] [SSL-0] [0_01111111_11111111111111111111111122222222223333333333444444444] 0:111 0:110 t=1394035150[0] r=[-1,64,15,1,1] sl=[17,64,64,272]
2014-03-05 10:59:11 write UDP []: Network is unreachable (code=101)
2014-03-05 10:59:11 write UDP []: Network is unreachable (code=101)
2014-03-05 10:59:14 Network Status: not connected
2014-03-05 10:59:14 MANAGEMENT: CMD 'signal SIGUSR1'
2014-03-05 10:59:14 TCP/UDP: Closing socket
2014-03-05 10:59:14 Sorry, deleting routes on Android is not possible. The VpnService API allows routes to be set on connect only.
2014-03-05 10:59:14 Sorry, deleting routes on Android is not possible. The VpnService API allows routes to be set on connect only.
2014-03-05 10:59:14 Closing TUN/TAP interface
2014-03-05 10:59:14 SIGUSR1[hard,] received, process restarting
2014-03-05 10:59:14 MANAGEMENT: >STATE:1394035154,RECONNECTING,SIGUSR1,,
2014-03-05 10:59:18 MANAGEMENT: CMD 'hold release'
2014-03-05 10:59:18 MANAGEMENT: CMD 'proxy NONE'
2014-03-05 10:59:18 MANAGEMENT: CMD 'bytecount 2'
2014-03-05 10:59:18 MANAGEMENT: CMD 'state on'
2014-03-05 10:59:18 Network Status: CONNECTED LTE to mobile VZWINTERNET
2014-03-05 10:59:19 LZO compression initializing
2014-03-05 10:59:19 Control Channel MTU parms [ L:1542 D:138 EF:38 EB:0 ET:0 EL:0 ]
2014-03-05 10:59:19 MANAGEMENT: >STATE:1394035159,RESOLVE,,,
2014-03-05 10:59:19 Data Channel MTU parms [ L:1542 D:1450 EF:42 EB:393 ET:0 EL:0 ]
2014-03-05 10:59:19 Local Options String: 'V4,dev-type tun,link-mtu 1542,tun-mtu 1500,proto UDPv4,comp-lzo,cipher BF-CBC,auth SHA1,keysize 128,key-method 2,tls-client'
2014-03-05 10:59:19 Expected Remote Options String: 'V4,dev-type tun,link-mtu 1542,tun-mtu 1500,proto UDPv4,comp-lzo,cipher BF-CBC,auth SHA1,keysize 128,key-method 2,tls-server'
2014-03-05 10:59:19 Local Options hash (VER=V4): '41690919'
2014-03-05 10:59:19 Expected Remote Options hash (VER=V4): '530fdded'
2014-03-05 10:59:19 TCP/UDP: Preserving recently used remote address: [AF_INET]50.7.31.18:1194
2014-03-05 10:59:19 Socket Buffers: R=[163840->131072] S=[163840->131072]
2014-03-05 10:59:19 Protecting socket fd 4
2014-03-05 10:59:19 MANAGEMENT: CMD 'needok 'PROTECTFD' ok'
2014-03-05 10:59:19 UDP link local (bound): [AF_INET][undef]:1194
2014-03-05 10:59:19 UDP link remote: [AF_INET]50.7.31.18:1194
2014-03-05 10:59:19 MANAGEMENT: >STATE:1394035159,WAIT,,,
2014-03-05 10:59:19 MANAGEMENT: >STATE:1394035159,AUTH,,,
2014-03-05 10:59:19 TLS: Initial packet from [AF_INET]50.7.31.18:1194, sid=58627c3f 06b21457
2014-03-05 10:59:20 VERIFY OK: depth=1, C=US, ST=OH, L=Columbus, O=Private Internet Access, CN=Private Internet Access CA, emailAddress=secure@privateinternetaccess.com
2014-03-05 10:59:20 Validating certificate key usage
2014-03-05 10:59:20 ++ Certificate has key usage 00a0, expects 00a0
2014-03-05 10:59:20 VERIFY KU OK
2014-03-05 10:59:20 Validating certificate extended key usage
2014-03-05 10:59:20 ++ Certificate has EKU (str) TLS Web Server Authentication, expects TLS Web Server Authentication
2014-03-05 10:59:20 VERIFY EKU OK
2014-03-05 10:59:20 VERIFY OK: depth=0, C=US, ST=OH, L=Columbus, O=Private Internet Access, CN=server, emailAddress=secure@privateinternetaccess.com
2014-03-05 10:59:20 Data Channel Encrypt: Cipher 'BF-CBC' initialized with 128 bit key
2014-03-05 10:59:20 Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
2014-03-05 10:59:20 Data Channel Decrypt: Cipher 'BF-CBC' initialized with 128 bit key
2014-03-05 10:59:20 Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
2014-03-05 10:59:20 Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 1024 bit RSA
2014-03-05 10:59:20 [server] Peer Connection Initiated with [AF_INET]50.7.31.18:1194
2014-03-05 10:59:21 MANAGEMENT: >STATE:1394035161,GET_CONFIG,,,
2014-03-05 10:59:23 SENT CONTROL [server]: 'PUSH_REQUEST' (status=1)
2014-03-05 10:59:23 PUSH: Received control message: 'PUSH_REPLY,redirect-gateway def1,dhcp-option DNS 209.222.18.222,dhcp-option DNS 209.222.18.218,ping 10,route 10.161.1.1,topology net30,ifconfig 10.161.1.6 10.161.1.5'
2014-03-05 10:59:23 OPTIONS IMPORT: timers and/or timeouts modified
2014-03-05 10:59:23 OPTIONS IMPORT: --ifconfig/up options modified
2014-03-05 10:59:23 OPTIONS IMPORT: route options modified
2014-03-05 10:59:23 OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified
2014-03-05 10:59:23 ROUTE_GATEWAY 10.188.107.65/255.255.255.192 IFACE=rmnet_usb0 HWADDR=00:00:00:00:00:00
2014-03-05 10:59:23 ROUTE6: default_gateway=UNDEF
2014-03-05 10:59:23 OpenVPN ROUTE6: OpenVPN needs a gateway parameter for a --route-ipv6 option and no default was specified by either --route-ipv6-gateway or --ifconfig-ipv6 options
2014-03-05 10:59:23 OpenVPN ROUTE: failed to parse/resolve route for host/network: ::/0
2014-03-05 10:59:23 do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
2014-03-05 10:59:23 MANAGEMENT: >STATE:1394035163,ASSIGN_IP,,10.161.1.6,
2014-03-05 10:59:23 MANAGEMENT: CMD 'needok 'IFCONFIG' ok'
2014-03-05 10:59:23 MANAGEMENT: CMD 'needok 'ROUTE' ok'
2014-03-05 10:59:23 MANAGEMENT: CMD 'needok 'ROUTE' ok'
2014-03-05 10:59:23 MANAGEMENT: >STATE:1394035163,ADD_ROUTES,,,
2014-03-05 10:59:23 MANAGEMENT: CMD 'needok 'ROUTE' ok'
2014-03-05 10:59:23 MANAGEMENT: CMD 'needok 'ROUTE' ok'
2014-03-05 10:59:23 MANAGEMENT: CMD 'needok 'DNSSERVER' ok'
2014-03-05 10:59:23 MANAGEMENT: CMD 'needok 'DNSSERVER' ok'
2014-03-05 10:59:23 MANAGEMENT: CMD 'needok 'PERSIST_TUN_ACTION' OPEN_AFTER_CLOSE'
2014-03-05 10:59:23 Opening tun interface:
2014-03-05 10:59:23 Local IPv4: 10.161.1.6/30 IPv6: null MTU: 1500
2014-03-05 10:59:23 DNS Server: 209.222.18.222, 209.222.18.218, Domain: null
2014-03-05 10:59:23 Routes: 0.0.0.0/1, 0.0.0.0/0, 10.161.1.1/32, 128.0.0.0/1 
2014-03-05 10:59:23 Routes excluded: 
2014-03-05 10:59:23 VpnService routes installed: 0.0.0.0/0 
2014-03-05 10:59:23 MANAGEMENT: CMD 'needok 'OPENTUN' ok'
2014-03-05 10:59:23 Initialization Sequence Completed
2014-03-05 10:59:23 MANAGEMENT: >STATE:1394035163,CONNECTED,SUCCESS,10.161.1.6,50.7.31.18
13th March 2014, 08:04 PM   |  #2  
OP Junior Member
Thanks Meter: 0
 
8 posts
Join Date:Joined: Oct 2010
No one can report about VPN functionality at all?
24th April 2014, 11:56 PM   |  #3  
Junior Member
Thanks Meter: 1
 
22 posts
Join Date:Joined: Nov 2010
Quote:
Originally Posted by raidscsi

No one can report about VPN functionality at all?

I have experienced the same issue on Nexus 5 using the PiA app. It doesn't seem to be limited to only LTE connections. Even with HSPA+, i was getting the data connection reset every couple of minutes. This was annoying because I was streaming a live cricket match on youtube using PiA connected to UK server
Last edited by BravoCharlieDelta; 25th April 2014 at 12:00 AM.
6th July 2014, 07:00 PM   |  #4  
Member
Thanks Meter: 5
 
40 posts
Join Date:Joined: Aug 2007
Unhappy
Quote:
Originally Posted by raidscsi

No one can report about VPN functionality at all?

Also confirmed on rooted stock Sprint Note 2 4.4.2 with PIA.

Did not occur on 4.2.
14th July 2014, 03:45 PM   |  #5  
RoboJoe's Avatar
Senior Member
Thanks Meter: 155
 
372 posts
Join Date:Joined: Jul 2010
I'm on Mahdi 4.4.4 with a LG G2 and I'm having this *exact* issue.

Did you ever manage to get it resolved?
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes