Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,732,846 Members 51,341 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Samsung Galaxy S5 losing network connectivity

Tip us?
 
krntehknik303
Old
#11  
Senior Member
Thanks Meter 46
Posts: 910
Join Date: Nov 2010
Location: Aurora
Quote:
Originally Posted by gr0wlithee View Post
I'm still having problems with this... I'm rooted. If I go to T-Mobile will they just replace the SIM or will they be checking my phone?

Sent from my SM-G900T using Tapatalk
From what I know T-Mobile doesn't care if your phone is rooted because you're not doing any warranty service. If that was the case they will probably tell you that its voided.. I have seen a few that root their own phones at their job so I doubt it'll be a problem. But I guess every T-Mobile store isn't the same..

Sent from my SM-G900T using XDA Premium 4 mobile app
 
Larry2148
Old
#12  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Jul 2014
Quote:
Originally Posted by pimpinonline View Post
My wife and I both have brand new Galaxy S5s, and we both intermittently experience this problem. One of us will send a text message to the other, the text will show as being sent, but the other person doesn't receive it. If the person set to receive the message reboots their phone, the message comes through (as well as any other "pending" messages), and normal phone use continues for a few days until this issue returns. Rebooting seems to always fix the issue temporarily.

This of course is not limited to just communication between our phones, but I was using that as an example. Often times, I'll reboot my phone, and realize I have 3 new text messages, and 2 voicemails from yesterday. Very frustrating.

Phone calls are also affected. When these symptoms are present, phone calls cannot be placed or received until the phone is rebooted. Incoming calls go directly to voicemail.

The worst part of it is, there is no easy way to tell our phones are not connected to the network. The reception status shows good connectivity. Most of the time we're connected to wifi, so email and browsing the internet still work.

I'm just wondering if other people are experiencing this, or have any suggestions of some things we can try. Thanks for the help.
Yes this is the exact problem I had with last GS5. Tmobile replaced it and I still have this problem with the new GS5. The tried to tell me it was just how the old GS5 settings were set. They had me do Factory reset many times, it never helped. Now with the replacement GS5 the exact same problem. Like you everything looks great on the display. I would just get calls on my home line wanting to know why I never answer my mobile phone. The only thing that helps me is a restart but it is only temporary. Do you know if they have released a fix for this problem?
 
pimpinonline
Old
#13  
Junior Member - OP
Thanks Meter 0
Posts: 22
Join Date: Oct 2006
Location: Seattle
Quote:
Originally Posted by Larry2148 View Post
Yes this is the exact problem I had with last GS5. Tmobile replaced it and I still have this problem with the new GS5. The tried to tell me it was just how the old GS5 settings were set. They had me do Factory reset many times, it never helped. Now with the replacement GS5 the exact same problem. Like you everything looks great on the display. I would just get calls on my home line wanting to know why I never answer my mobile phone. The only thing that helps me is a restart but it is only temporary. Do you know if they have released a fix for this problem?
Since upgrading the latest firmware, we have not experienced the problems again. We've been having good service since then. I would definitely suggest you get the latest firmware.
Tags
connectivity, galaxy s5, missed calls, missed text messages
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...