Post Reply

Google Dialer Crashes

OP Imriela

25th June 2014, 09:21 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: May 2014
More
So I sideloaded the Google Dialer from the Nexus devices on my rooted Verizon Galaxy S5. I downloaded the APK, copied it to /system/priv-app, changed the permissions to 644 (rw-r--r--), then ran the APK to install the dialer. I tried launching both from the app drawer and through Nova's shorcut, Actions, Google Dialer and then the first phone option; both ways loads the launcher and then immediately crashes with the error "Unfortunately, Google Dialer has stopped." Has anybody had any success getting the Google Dialer to work on their Galaxy S5? If so, any workarounds that you had to do to get it to work or did it just work? I'm wondering if it's because I froze a bloatware or installed an app that's causing a conflict. My stock Samsung dialer works fine, but I'm not a fan of that dialer and I like the local business search feature of the Google Dialer.
26th June 2014, 05:21 AM   |  #2  
Member
Flag Sydney
Thanks Meter: 1
 
40 posts
Join Date:Joined: Jun 2014
More
I installed it, but it crashes as soon as I try to search for a person (type any key and crash). I'm not really interested in rooting my phone til CM is ready, but I hear you need to to get it working properly.
8th July 2014, 09:54 PM   |  #3  
HD-man's Avatar
Senior Member
Flag Dayton
Thanks Meter: 39
 
190 posts
Join Date:Joined: Apr 2013
Donate to Me
More
Crashing here too, something with S5 firmware or software?
Last edited by HD-man; 8th July 2014 at 09:59 PM.
15th July 2014, 01:53 AM   |  #4  
Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Jul 2014
Same here
I'm on a Verizon Galaxy S5 rooted with GEL and I tried making a shortcut to the Google Dialer with QuickShortcutMaker. The dialer crashes every time. Would love to be able to use the Google Dialer again. Coming from CM11 on a Galaxy Nexus.
15th July 2014, 10:46 AM   |  #5  
fffft's Avatar
Senior Member
Thanks Meter: 555
 
1,893 posts
Join Date:Joined: Jul 2013
To stop it crashing, you need to clear your system caches.

Go to the Applications manager in the Settings menu and find the Google dialer in the "all" column
Choose force stop > clear cache > clear data

Now reboot to recovery mode (power phone down, then volume up + home + power)
And select clear cache
Then a normal reboot and you should be good

.
Last edited by fffft; 15th July 2014 at 12:46 PM.
The Following User Says Thank You to fffft For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Galaxy S 5 Q&A, Help & Troubleshooting by ThreadRank