Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,809,576 Members 37,553 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Jiayu G4S How to unbrick ?

Tip us?
 
godhamer
Old
(Last edited by godhamer; 26th June 2014 at 07:08 AM.)
#1  
Member - OP
Thanks Meter 3
Posts: 37
Join Date: Nov 2009
Default [Q] Jiayu G4S How to unbrick ?

Hello!
Today I tried to change ROM. But something goes wrong I followed all instructions but apparently I pushed Format + Download now does not want to boot. May be it is bricked.
Everything is installed correctly !
Drivers, SP_Flash_Tool_v5.1348.00, Stock ROM from official web site.
I get these errors:
BROM ERROR...
Firmware Upgrade error
Nand flash not detected

If you need more information about the problem I will try to explain.
 
ereeme
Old
#2  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Jun 2014
Default The same problem

Hi, seems to be the same with my phone.
Maybe preloader file is not siutable? I think if I would unthick preloader file while I was trying to flash it would be fine. Maybe we need proper preloader file from factory ROM. Anyone who has original working G4SL 1GB/4GB could do flashable backup using MTK Droid Tools and post it somewhere please? It would probably unbrick our phones. Tutorial and download links here for example http://www.needrom.com/mobile/.....roidtools/ . Thank you in advance….

If no and there is problem with accesing NAND flash... I don't know what we can do...format it? Set proper size somehow?
There was similar problem with MTK6577 here http://forum.xda-developers.com/show....php?t=1866962
I tried this SPMultiPortFlashDownloadProject but it doesn't load any configuration files...

Some one with ideas, please?
 
ereeme
Old
#3  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Jun 2014
Default It works!

Hi It was problem with wrong ROMs. Yesterday they release new ROM on needrom + new SP Flash tools and was no problem to install everything It works again.
 
barut78
Old
#4  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Jul 2014
Default hi

I have the same problem
Did you make?
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes