Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,805,892 Members 43,117 Now Online
XDA Developers Android and Mobile Development Forum

Help - No IMEI - Can't upgrade/downgrade Firmware

Tip us?
 
monkeyass
Old
#1  
Junior Member - OP
Thanks Meter 2
Posts: 26
Join Date: Dec 2007
Default Help - No IMEI - Can't upgrade/downgrade Firmware

Hello,

Looking for a bit of help here.

I have just recently purchased a mobile phone off Ebay where the IMEI is missing.

I have read the following article thinking that it would be a simple fix, only to find that I seem to be unable to connect to the phone when using Tutty.

http://forum.xda-developers.com/show....php?t=2280249

I have checked the IMEI and found that it is authorised on the LG site

<response req_cmd="auth_model_check" status="OK">
<auth_model_check><result>OK</result>
<esn>***************</esn>
<model>LGP880</model>
<suffix>AGBRBK</suffix>
<msn>20*********779</msn>
<sw_version>V20A_00</sw_version>
<sw_url>http://csmgdl.lgmobile.com/dn/downloader.dev?fileKey=FW***************/V20A_00.kdz</sw_url>
<cs_em_flag>N</cs_em_flag>
<cs_em_uri>N</cs_em_uri>
<chip_type>EI</chip_type>
<prod_type>GSM</prod_type>
</auth_model_check>
</response>

I have downloaded the subsequent KDZ file from the link of the LG website, however this leads to my second problem.

When attempting to upgrade the firmware of my phone i receive failure to upload the software, within the LGFlashTool, UpTestEx_mod2_marwin and KDZ_FW_UPD.

With FLFlashTool I have followed the below instructions

http://forum.xda-developers.com/show....php?t=1843830

I am successful in getting a connection that links on COM port 1, I remove the usb cable when the program says ready and plug back in. The program begins, it skips to 7% then to 10% after 17 seconds I receive an error message Failed Upload, Failure : 207.

Using KDZ or UpTest I get the following:

09:06:59 : Start fn_StartUpgrade
09:06:59 : Extract kdz file
09:07:05 : kdz decrypt Success
09:07:08 : Extract file Success.
09:07:08 : LGMobileDL Load.
09:07:08 : Port = -1
09:07:08 : Connection check start.
09:07:22 : Check Phone mode = 2
09:07:22 : Phone type check.......
09:07:24 : LGMobileDL.DLL Loading....
09:07:24 : _SetAuthMark Fail
09:07:24 : _SetAuthMark Ok : wAuthMark(65535)
09:07:24 : _DetachDLL Call
09:07:24 : _DetachDLL Call End
09:07:24 : Param : Path = C:\ProgramData\LGMOBILEAX\Phone\LGP880AT-00-V20a-234-000-MAR-26-2013+0.dz
09:07:24 : Param : moduleDir =
09:07:24 : Param : waitTime = -1970404774
09:07:24 : Param : UsbHighSpeed = 1
09:07:24 : Param : PhoneMode = 2
09:07:24 : Param : BinVersion = V20A_00(1)
09:07:24 : Param : AuthMark = 65535
09:07:24 : Call fn_StartUpgrade
09:07:24 : 3GQCT : wParam = 2005, lParam = 0
09:07:24 : 3GQCT : wParam = 2005, lParam = 4
09:07:24 : 3GQCT : wParam = 2003, lParam = 5
09:07:24 : 3GQCT : wParam = 2005, lParam = 4
09:07:34 : 3GQCT : wParam = 2005, lParam = 0
09:07:34 : 3GQCT : wParam = 2005, lParam = 1
09:07:34 : 3GQCT : wParam = 2003, lParam = 3015
09:07:34 : 3GQCT : wParam = 2003, lParam = 1
09:07:34 : 3GQCT : wParam = 2005, lParam = 1
09:07:34 : 3GQCT : wParam = 2003, lParam = 1
09:07:34 : 3GQCT : wParam = 2005, lParam = 1
09:07:34 : 3GQCT : wParam = 2005, lParam = 2
09:07:34 : 3GQCT : wParam = 2005, lParam = 3
09:07:34 : 3GQCT : wParam = 2003, lParam = 3
09:07:34 : 3GQCT : wParam = 2005, lParam = 3
09:07:34 : 3GQCT : wParam = 2005, lParam = 4
09:07:34 : 3GQCT : wParam = 2005, lParam = 5
09:07:34 : 3GQCT : wParam = 2007, lParam = 0
09:07:34 : 3GQCT : wParam = 2005, lParam = 5
09:07:34 : 3GQCT : wParam = 2003, lParam = 201
09:07:34 : 3GQCT : wParam = 2005, lParam = 5
09:07:35 : 3GQCT : wParam = 2003, lParam = 401
09:07:35 : 3GQCT : wParam = 2005, lParam = 5
09:07:35 : 3GQCT : wParam = 2003, lParam = 200
09:07:35 : 3GQCT : wParam = 2005, lParam = 5
09:07:35 : 3GQCT : wParam = 2003, lParam = 202
09:07:35 : 3GQCT : wParam = 2005, lParam = 5
09:07:35 : 3GQCT : wParam = 2003, lParam = 203
09:07:35 : 3GQCT : wParam = 2005, lParam = 5
09:07:38 : 3GQCT : wParam = 2005, lParam = 10
09:07:38 : 3GQCT : wParam = 2003, lParam = 204
09:07:38 : 3GQCT : wParam = 2005, lParam = 10
09:07:52 : 3GQCT : wParam = 2003, lParam = 205
09:07:52 : 3GQCT : wParam = 2005, lParam = 10
09:07:52 : 3GQCT : wParam = 2003, lParam = 206
09:07:52 : 3GQCT : wParam = 2005, lParam = 10
09:07:52 : 3GQCT : wParam = 2003, lParam = 207
09:07:52 : 3GQCT : wParam = 2005, lParam = 10
09:07:52 : 3GQCT : wParam = 2010, lParam = 207

I really have no idea what the meaning is behind the different states wparam and lparam, no matter how long I leave the phone it just sits there.

The other possibility is it could be a dev phone, but there is no 'not for sale' sign on the phone and the software version in settings is V10h, unless the last person that had it already upgraded and mucked it up.

I am at a loss and looking for some help,

Any will be greatly appreciated

If you require further information please ask,

Thank you in advance,
Monkey
 
monkeyass
Old
#2  
Junior Member - OP
Thanks Meter 2
Posts: 26
Join Date: Dec 2007
Default Extra info

Just for some extra information, I thought it may be the usb connection, so i bought a new usb PCB board for the phone but to no avail, what i have written above is what is happening with the new USB connection.

I am finding a strange thing happen when I attempt to connect the phone on USB, I get the option of using Media Sync or LG software. Under both when i try to access the internal storage of the phone from My Computer the window closes in Windows, the phone also seems to have a fit, the connection to the pc starts then stops multiple times before it connects again.

Maybe it is a dodgy USB connection that I bought, I can try the original again, or maybe it is something else in the phone.

Think I may have to give up with this one.
 
Aborrajado
Old
#3  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Apr 2014
Quote:
Originally Posted by monkeyass View Post
Just for some extra information, I thought it may be the usb connection, so i bought a new usb PCB board for the phone but to no avail, what i have written above is what is happening with the new USB connection.

I am finding a strange thing happen when I attempt to connect the phone on USB, I get the option of using Media Sync or LG software. Under both when i try to access the internal storage of the phone from My Computer the window closes in Windows, the phone also seems to have a fit, the connection to the pc starts then stops multiple times before it connects again.

Maybe it is a dodgy USB connection that I bought, I can try the original again, or maybe it is something else in the phone.

Think I may have to give up with this one.
Same problem here, Ive tried to downgrade with the same results.
Using KDZ or UpTest I get the following:

09:06:59 : Start fn_StartUpgrade
09:06:59 : Extract kdz file
09:07:05 : kdz decrypt Success
09:07:08 : Extract file Success.
09:07:08 : LGMobileDL Load.
09:07:08 : Port = -1
09:07:08 : Connection check start.
09:07:22 : Check Phone mode = 2
09:07:22 : Phone type check.......
09:07:24 : LGMobileDL.DLL Loading....
09:07:24 : _SetAuthMark Fail
09:07:24 : _SetAuthMark Ok : wAuthMark(65535)
09:07:24 : _DetachDLL Call
09:07:24 : _DetachDLL Call End
09:07:24 : Param : Path = C:\ProgramData\LGMOBILEAX\Phone\LGP880AT-00-V20a-234-000-MAR-26-2013+0.dz
09:07:24 : Param : moduleDir =
09:07:24 : Param : waitTime = -1970404774
09:07:24 : Param : UsbHighSpeed = 1
09:07:24 : Param : PhoneMode = 2
09:07:24 : Param : BinVersion = V20A_00(1)
09:07:24 : Param : AuthMark = 65535
09:07:24 : Call fn_StartUpgrade
09:07:24 : 3GQCT : wParam = 2005, lParam = 0
09:07:24 : 3GQCT : wParam = 2005, lParam = 4
09:07:24 : 3GQCT : wParam = 2003, lParam = 5
09:07:24 : 3GQCT : wParam = 2005, lParam = 4
09:07:34 : 3GQCT : wParam = 2005, lParam = 0
09:07:34 : 3GQCT : wParam = 2005, lParam = 1
09:07:34 : 3GQCT : wParam = 2003, lParam = 3015
09:07:34 : 3GQCT : wParam = 2003, lParam = 1
09:07:34 : 3GQCT : wParam = 2005, lParam = 1
09:07:34 : 3GQCT : wParam = 2003, lParam = 1
09:07:34 : 3GQCT : wParam = 2005, lParam = 1
09:07:34 : 3GQCT : wParam = 2005, lParam = 2
09:07:34 : 3GQCT : wParam = 2005, lParam = 3
09:07:34 : 3GQCT : wParam = 2003, lParam = 3
09:07:34 : 3GQCT : wParam = 2005, lParam = 3
09:07:34 : 3GQCT : wParam = 2005, lParam = 4
09:07:34 : 3GQCT : wParam = 2005, lParam = 5
09:07:34 : 3GQCT : wParam = 2007, lParam = 0
09:07:34 : 3GQCT : wParam = 2005, lParam = 5
09:07:34 : 3GQCT : wParam = 2003, lParam = 201
09:07:34 : 3GQCT : wParam = 2005, lParam = 5
09:07:35 : 3GQCT : wParam = 2003, lParam = 401
09:07:35 : 3GQCT : wParam = 2005, lParam = 5
09:07:35 : 3GQCT : wParam = 2003, lParam = 200
09:07:35 : 3GQCT : wParam = 2005, lParam = 5
09:07:35 : 3GQCT : wParam = 2003, lParam = 202
09:07:35 : 3GQCT : wParam = 2005, lParam = 5
09:07:35 : 3GQCT : wParam = 2003, lParam = 203
09:07:35 : 3GQCT : wParam = 2005, lParam = 5
09:07:38 : 3GQCT : wParam = 2005, lParam = 10
09:07:38 : 3GQCT : wParam = 2003, lParam = 204
09:07:38 : 3GQCT : wParam = 2005, lParam = 10
09:07:52 : 3GQCT : wParam = 2003, lParam = 205
09:07:52 : 3GQCT : wParam = 2005, lParam = 10
09:07:52 : 3GQCT : wParam = 2003, lParam = 206
09:07:52 : 3GQCT : wParam = 2005, lParam = 10
09:07:52 : 3GQCT : wParam = 2003, lParam = 207
09:07:52 : 3GQCT : wParam = 2005, lParam = 10
09:07:52 : 3GQCT : wParam = 2010, lParam = 207

Then the phone gets stuck and it never reboots, using LGFlashTool port 4 it keeps resetting over and over again, I thought it was the USB cable but reading what you wrote its probably not the problem, I suggest you look for a folder called efs where is supposed to be the IMEI of your phone, if you have it you might be able to do some sort of recovery, Ive found some guides on google but unfortunately I dont have the folder and didnt back it up, anyways, if you find out whats happened to our phone let us know. Thanks

---------- Post added at 11:05 PM ---------- Previous post was at 10:35 PM ----------

Quote:
Originally Posted by monkeyass View Post
Just for some extra information, I thought it may be the usb connection, so i bought a new usb PCB board for the phone but to no avail, what i have written above is what is happening with the new USB connection.

I am finding a strange thing happen when I attempt to connect the phone on USB, I get the option of using Media Sync or LG software. Under both when i try to access the internal storage of the phone from My Computer the window closes in Windows, the phone also seems to have a fit, the connection to the pc starts then stops multiple times before it connects again.

Maybe it is a dodgy USB connection that I bought, I can try the original again, or maybe it is something else in the phone.

Think I may have to give up with this one.
Forgot to add, I flashed kdzs with no problems at all about a year ago, then I unlocked the bootloader and started to flash roms in the following order: Zaiben ZRC3, werewolf, Vanyr, and finally stayed with Zaiben ZRC3 where one day just couldnt get any signal and the imei appeared as null.

Ive tried this youtube/watch?v=rPHdI0bYf2U, installing differents roms and going back to stock but I cant manage to restore my imei without the efs folder.

My phone is brand new not a dev one, any help will be appreciated.

Thanks
 
monkeyass
Old
#4  
Junior Member - OP
Thanks Meter 2
Posts: 26
Join Date: Dec 2007
Default Tried something

Tried the old USB PCB and RIBBON, still receive the same error message.

So it may not be the USB connection.

I cannot see any damaged pins on the connector to the main board.

I found out what WParam and LParam are but I do not know what the numbers refer to.

Whether the numbers are generic to Windows or specific to the LG software and/or hardware
 
vendroidlabs
Old
#5  
Junior Member
Thanks Meter 1
Posts: 8
Join Date: May 2013
Does anyone have any update? I am having the same issue at my end
 
dr_m_fahmy
Old
#6  
Junior Member
Thanks Meter 0
Posts: 6
Join Date: Oct 2013
Default same problem .. dead end

I have the same problem ... i tried reflashing it by all methods with no change ... i think it has somthing to do with unlocking bootloader as it says " " bootloader state : unlocked " ... so supposedly relocking the bootloader or recovery of the original OEM one would be helpful !
 
monkeyass
Old
#7  
Junior Member - OP
Thanks Meter 2
Posts: 26
Join Date: Dec 2007
Default Tried LG

You can guess the response I received from LG.

No warranty, no help.

Which is fair enough, all I really want is an understanding of what the codes mean.

Nevermind.
 
roscoe182
Old
#8  
Junior Member
Thanks Meter 1
Posts: 24
Join Date: Aug 2011
same here i have had the problem for a long time.
i had no luck doing any thing i use the fone as more of a tablet now.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes